summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDmitry Kozlov <xeb@mail.ru>2016-07-09 20:22:34 +0300
committerDmitry Kozlov <xeb@mail.ru>2016-07-09 20:22:40 +0300
commit6fb04941ca41312909208938bfac4f753d3c277c (patch)
tree3673e6d312616793c739b4fe557055bff98db6af /CMakeLists.txt
parentff364ceb8a6c92c7da630c4bc408e888ac3d9266 (diff)
downloadaccel-ppp-6fb04941ca41312909208938bfac4f753d3c277c.tar.gz
accel-ppp-6fb04941ca41312909208938bfac4f753d3c277c.zip
1.11.0 release
* general rewrite and improve ipoe/vlan_mon drivers * ipoe: generate EUI-64 interface identifier for ipv6 addresses * ipoe: log warning if interface was not started by vlan_mon notification * ipoe: introduced option "start=auto" * ipoe: translate UP session to dhcp session when dhcp request received (for shared=0 interfaces) * ipoe: implemented starting UP session by arp request * ipoe: log interface renaming * pppoe: add interface name to log messages * pppoe: implemented vlan_mon support * pppd_compat: change mode of radattr files to 0644 * pppd_compat: check for script existance before fork * radius: implemented handling of Framed-Route attribute * radius: do not send NAS-Port and NAS-Port-Id if they are undefined * radius: add Delegated-IPv6-Prefix to accounting packets * radius: update Session-Timeout by CoA * shaper: implemented internal class id map * ppp: introduced unit-preallocate option * ipv6: remove ipv6 address and routes on session termination * vlan_mon: introduced autoclean module parameter * iprange: implement config reload * make termination caused by SIGTERM soft * remove pid file on exit * for single-session=deny make early check for duplicate username (before calling radius) * fixed broken "noauth" mode
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 93889cd2..8cf2b901 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -34,7 +34,7 @@ IF (EXISTS ${CMAKE_HOME_DIRECTORY}/.git AND NOT IGNORE_GIT)
)
STRING(STRIP ${ACCEL_PPP_VERSION} ACCEL_PPP_VERSION)
ELSE (EXISTS ${CMAKE_HOME_DIRECTORY}/.git AND NOT IGNORE_GIT)
- SET (ACCEL_PPP_VERSION 1.10.0)
+ SET (ACCEL_PPP_VERSION 1.11.0)
ENDIF (EXISTS ${CMAKE_HOME_DIRECTORY}/.git AND NOT IGNORE_GIT)
ADD_DEFINITIONS(-DACCEL_PPP_VERSION="${ACCEL_PPP_VERSION}")