summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Poessinger <christian@poessinger.com>2020-03-22 12:56:22 +0100
committerChristian Poessinger <christian@poessinger.com>2020-03-22 12:57:21 +0100
commit9f3a32932eecb8fbf9ed4f747d7713380fbfc889 (patch)
tree0ce51a38c23810da30a5e2c4e05b706c22ebe0db /CMakeLists.txt
parent801ac421795b97f69230c4404a7f3a6eb17f9dec (diff)
downloadaccel-ppp-9f3a32932eecb8fbf9ed4f747d7713380fbfc889.tar.gz
accel-ppp-9f3a32932eecb8fbf9ed4f747d7713380fbfc889.zip
cpack: remove duplicate version number definition
Version number for Accel-PPP is already generated in CMakeLists.txt and thus it should not be manually defined in a second place (cmake/cpack.cmake). Reuse the version number obtained in CMakeLists.txt when building binary packages -> single source. Signed-off-by: Christian Poessinger <christian@poessinger.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 5 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fe8ac947..4d86ff70 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -8,8 +8,6 @@ endif ()
project(accel-ppp C)
-include(cmake/cpack.cmake)
-
SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -fno-strict-aliasing -D_GNU_SOURCE -fPIC -rdynamic -Wno-unused-result")
IF (NOT DEFINED LIB_SUFFIX)
@@ -51,6 +49,9 @@ ELSE (EXISTS ${CMAKE_HOME_DIRECTORY}/.git AND NOT IGNORE_GIT)
SET (ACCEL_PPP_VERSION 1.12.0)
ENDIF (EXISTS ${CMAKE_HOME_DIRECTORY}/.git AND NOT IGNORE_GIT)
+# we must include cpack.cmake after generating the ACCEL_PPP_VERSION variable
+include(cmake/cpack.cmake)
+
ADD_DEFINITIONS(-DACCEL_PPP_VERSION="${ACCEL_PPP_VERSION}")
INCLUDE_DIRECTORIES(${CMAKE_CURRENT_BINARY_DIR})
@@ -62,7 +63,7 @@ if (NOT BUILD_DRIVER_ONLY)
if (NOT DEFINED CRYPTO)
set(CRYPTO OPENSSL)
endif (NOT DEFINED CRYPTO)
-
+
if (CRYPTO STREQUAL OPENSSL)
find_library(CRYPTO_LIBRARY ssl
HINTS ${CMAKE_SOURCE_DIR}/lib/linux/gcc/${BIT}/lib
@@ -83,7 +84,7 @@ if (NOT BUILD_DRIVER_ONLY)
else (CRYPTO STREQUAL OPENSSL)
message(FATAL_ERROR "unknown CRYPTO type")
endif (CRYPTO STREQUAL OPENSSL)
-
+
add_subdirectory(accel-pppd)
add_subdirectory(crypto)
add_subdirectory(accel-cmd)