summaryrefslogtreecommitdiff
path: root/contrib/gentoo/net-dialup/accel-pptp
diff options
context:
space:
mode:
authorDmitry Kozlov <xeb@mail.ru>2011-01-08 14:22:46 +0300
committerDmitry Kozlov <xeb@mail.ru>2011-01-08 14:22:46 +0300
commitb98f515daa345fb83002a149c1f1f33a7b4644e7 (patch)
tree89c1aeb1c047ea5c1b4be7bc1782c0d099904ef9 /contrib/gentoo/net-dialup/accel-pptp
parent53f22bd8a8cd4a407b7eb9c9b034b215e2299e30 (diff)
downloadaccel-ppp-b98f515daa345fb83002a149c1f1f33a7b4644e7.tar.gz
accel-ppp-b98f515daa345fb83002a149c1f1f33a7b4644e7.zip
updated contrib files
Diffstat (limited to 'contrib/gentoo/net-dialup/accel-pptp')
-rw-r--r--contrib/gentoo/net-dialup/accel-pptp/accel-pptp-1.1.1.ebuild80
-rw-r--r--contrib/gentoo/net-dialup/accel-pptp/accel-pptp-9999.ebuild84
-rw-r--r--contrib/gentoo/net-dialup/accel-pptp/files/pptpd-confd5
-rwxr-xr-xcontrib/gentoo/net-dialup/accel-pptp/files/pptpd-init20
4 files changed, 0 insertions, 189 deletions
diff --git a/contrib/gentoo/net-dialup/accel-pptp/accel-pptp-1.1.1.ebuild b/contrib/gentoo/net-dialup/accel-pptp/accel-pptp-1.1.1.ebuild
deleted file mode 100644
index 7555c184..00000000
--- a/contrib/gentoo/net-dialup/accel-pptp/accel-pptp-1.1.1.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=2
-
-inherit eutils linux-mod cmake-utils
-
-DESCRIPTION="Point-to-Point Tunnelling Protocol Client/Server for Linux"
-SRC_URI="http://sourceforge.net/projects/accel-pptp/files/accel-pptp/${P}.tar.bz2"
-HOMEPAGE="http://accel-pptp.sourceforge.net/"
-
-SLOT="0"
-LICENSE="GPL"
-KEYWORDS="~amd64 ~x86"
-IUSE="postgres debug l2tp shaper"
-
-DEPEND=">=sys-libs/glibc-2.8
- dev-libs/openssl
- dev-libs/libaio
- l2tp? ( =dev-libs/libnl-9999 )
- shaper? ( =dev-libs/libnl-9999 )
- postgres? ( >=dev-db/postgresql-base-8.1 )"
-
-RDEPEND="$DEPEND
- virtual/modutils"
-
-BUILD_TARGETS="default"
-BUILD_PARAMS="KDIR=${KERNEL_DIR}"
-CONFIG_CHECK="PPP PPPOE"
-MODULESD_PPTP_ALIASES=("net-pf-24 pptp")
-PREFIX="/"
-MODULE_NAMES="pptp(extra:${S}/driver/)"
-
-src_prepare() {
- sed -i -e "/mkdir/d" "${S}/accel-pptpd/CMakeLists.txt"
- sed -i -e "/INSTALL/d" "${S}/driver/CMakeLists.txt"
-}
-
-src_configure() {
- if use debug; then
- mycmakeargs+=( "-DCMAKE_BUILD_TYPE=Debug" )
- fi
-
- if use postgres; then
- mycmakeargs+=( "-DLOG_PGSQL=TRUE" )
- fi
-
- if use l2tp; then
- mycmakeargs+=( "-DL2TP=TRUE" )
- fi
-
- if use shaper; then
- mycmakeargs+=( "-DSHAPER=TRUE" )
- fi
-
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
-
- cd ${S}/driver
- linux-mod_src_compile || die "failed to build driver"
-}
-
-src_install() {
- cmake-utils_src_install
-
- cd ${S}/driver
- linux-mod_src_install
-
- exeinto /etc/init.d
- newexe "${S}/contrib/gentoo/net-dialup/accel-pptp/files/pptpd-init" accel-pptpd
-
- insinto /etc/conf.d
- newins "${S}/contrib/gentoo/net-dialup/accel-pptp/files/pptpd-confd" accel-pptpd
-
- dodir /var/log/accel-pptp
- dodir /var/run/radattr
-}
diff --git a/contrib/gentoo/net-dialup/accel-pptp/accel-pptp-9999.ebuild b/contrib/gentoo/net-dialup/accel-pptp/accel-pptp-9999.ebuild
deleted file mode 100644
index cd158d60..00000000
--- a/contrib/gentoo/net-dialup/accel-pptp/accel-pptp-9999.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=2
-
-inherit eutils git linux-mod cmake-utils
-
-EGIT_REPO_URI="git://accel-pptp.git.sourceforge.net/gitroot/accel-pptp/accel-pptp"
-
-DESCRIPTION="Point-to-Point Tunnelling Protocol Client/Server for Linux"
-SRC_URI=""
-HOMEPAGE="http://accel-pptp.sourceforge.net/"
-
-SLOT="0"
-LICENSE="GPL"
-KEYWORDS="~amd64 ~x86"
-IUSE="postgres debug shaper"
-
-DEPEND=">=sys-libs/glibc-2.8
- dev-libs/openssl
- dev-libs/libaio
- shaper? ( =dev-libs/libnl-2 )
- postgres? ( >=dev-db/postgresql-base-8.1 )"
-
-RDEPEND="$DEPEND
- virtual/modutils"
-
-BUILD_TARGETS="default"
-BUILD_PARAMS="KDIR=${KERNEL_DIR}"
-CONFIG_CHECK="PPP PPPOE"
-MODULESD_PPTP_ALIASES=("net-pf-24 pptp")
-PREFIX="/"
-MODULE_NAMES="pptp(extra:${S}/driver/)"
-
-src_unpack () {
- git_src_unpack
-}
-
-src_prepare() {
- sed -i -e "/mkdir/d" "${S}/accel-pptpd/CMakeLists.txt"
- sed -i -e "/echo/d" "${S}/accel-pptpd/CMakeLists.txt"
- sed -i -e "/INSTALL/d" "${S}/driver/CMakeLists.txt"
-}
-
-src_configure() {
- if use debug; then
- mycmakeargs+=( "-DCMAKE_BUILD_TYPE=Debug" )
- fi
-
- if use postgres; then
- mycmakeargs+=( "-DLOG_PGSQL=TRUE" )
- fi
-
- if use shaper; then
- mycmakeargs+=( "-DSHAPER=TRUE" )
- fi
-
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
-
- cd ${S}/driver
- #convert_to_m Makefile
- linux-mod_src_compile || die "failed to build driver"
-}
-
-src_install() {
- cmake-utils_src_install
-
- cd ${S}/driver
- linux-mod_src_install
-
- exeinto /etc/init.d
- newexe "${S}/contrib/gentoo/net-dialup/accel-pptp/files/pptpd-init" accel-pptpd
-
- insinto /etc/conf.d
- newins "${S}/contrib/gentoo/net-dialup/accel-pptp/files/pptpd-confd" accel-pptpd
-
- dodir /var/log/accel-pptp
- dodir /var/run/accel-pptp
- dodir /var/run/radattr
-}
diff --git a/contrib/gentoo/net-dialup/accel-pptp/files/pptpd-confd b/contrib/gentoo/net-dialup/accel-pptp/files/pptpd-confd
deleted file mode 100644
index ddc7aed9..00000000
--- a/contrib/gentoo/net-dialup/accel-pptp/files/pptpd-confd
+++ /dev/null
@@ -1,5 +0,0 @@
-# Config file for /etc/init.d/accel-pptpd
-
-# Any extra options you want to pass to pptpd
-# on start-up should be put here.
-PPTPD_OPTS="-d -c /etc/accel-pptp.conf"
diff --git a/contrib/gentoo/net-dialup/accel-pptp/files/pptpd-init b/contrib/gentoo/net-dialup/accel-pptp/files/pptpd-init
deleted file mode 100755
index f9155b4c..00000000
--- a/contrib/gentoo/net-dialup/accel-pptp/files/pptpd-init
+++ /dev/null
@@ -1,20 +0,0 @@
-#!/sbin/runscript
-
-depend() {
- need net
-}
-
-start() {
- ebegin "Starting accel-pptpd"
- start-stop-daemon --start --quiet --exec /usr/sbin/accel-pptpd -- -p /var/run/pptpd.pid ${PPTPD_OPTS}
- eend $?
-}
-
-stop() {
- ebegin "Stopping accel-pptpd"
- start-stop-daemon --stop --quiet --pidfile /var/run/pptpd.pid
- result=$?
- start-stop-daemon --stop --quiet --oknodo --exec /usr/sbin/accel-pptpd
- result=$(( $result + $? ))
- eend $result
-}