summaryrefslogtreecommitdiff
path: root/crypto/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'crypto/CMakeLists.txt')
-rw-r--r--crypto/CMakeLists.txt18
1 files changed, 11 insertions, 7 deletions
diff --git a/crypto/CMakeLists.txt b/crypto/CMakeLists.txt
index f7413113..6df9fa73 100644
--- a/crypto/CMakeLists.txt
+++ b/crypto/CMakeLists.txt
@@ -1,17 +1,21 @@
-IF (CRYPTO STREQUAL INTERNAL)
+INCLUDE_DIRECTORIES(${CMAKE_CURRENT_SOURCE_DIR})
+
+SET(sources crypto.c)
+IF (CRYPTO STREQUAL INTERNAL)
SET(sources
+ ${sources}
crypto.c
md4.c
md5.c
sha1.c
des.c
)
+ENDIF(CRYPTO STREQUAL INTERNAL)
- ADD_LIBRARY(internal-crypto SHARED ${sources})
-
- INSTALL(TARGETS internal-crypto
- LIBRARY DESTINATION lib/accel-ppp
- )
+ADD_LIBRARY(internal-crypto SHARED ${sources})
+IF (CRYPTO STREQUAL TOMCRYPT)
+ TARGET_LINK_LIBRARIES(internal-crypto tomcrypt)
+ENDIF(CRYPTO STREQUAL TOMCRYPT)
-ENDIF (CRYPTO STREQUAL INTERNAL)
+INSTALL(TARGETS internal-crypto LIBRARY DESTINATION lib${LIB_SUFFIX}/accel-ppp )