summaryrefslogtreecommitdiff
path: root/crypto/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'crypto/CMakeLists.txt')
-rw-r--r--crypto/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/crypto/CMakeLists.txt b/crypto/CMakeLists.txt
new file mode 100644
index 00000000..f7413113
--- /dev/null
+++ b/crypto/CMakeLists.txt
@@ -0,0 +1,17 @@
+IF (CRYPTO STREQUAL INTERNAL)
+
+ SET(sources
+ crypto.c
+ md4.c
+ md5.c
+ sha1.c
+ des.c
+ )
+
+ ADD_LIBRARY(internal-crypto SHARED ${sources})
+
+ INSTALL(TARGETS internal-crypto
+ LIBRARY DESTINATION lib/accel-ppp
+ )
+
+ENDIF (CRYPTO STREQUAL INTERNAL)