summaryrefslogtreecommitdiff
path: root/accel-pptpd/CMakeLists.txt
diff options
context:
space:
mode:
authorDmitry Kozlov <xeb@mail.ru>2011-01-03 00:51:11 +0300
committerDmitry Kozlov <xeb@mail.ru>2011-01-03 00:51:11 +0300
commit6409b409508f22ea7dbb3f3fa2cb9de78d5073c5 (patch)
tree1ebd296d3f459103a9459695524c56c0bcbd2f1d /accel-pptpd/CMakeLists.txt
parent95a19e0c5c622e8e886ff822ea48d28f7bceced4 (diff)
downloadaccel-ppp-xebd-6409b409508f22ea7dbb3f3fa2cb9de78d5073c5.tar.gz
accel-ppp-xebd-6409b409508f22ea7dbb3f3fa2cb9de78d5073c5.zip
core: rewrited to don't use getcontext/swapcontext due to *context functions works buggy on some combinations of kernel/gcc/glibc
Diffstat (limited to 'accel-pptpd/CMakeLists.txt')
-rw-r--r--accel-pptpd/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/accel-pptpd/CMakeLists.txt b/accel-pptpd/CMakeLists.txt
index b6b5498..e0a8dd4 100644
--- a/accel-pptpd/CMakeLists.txt
+++ b/accel-pptpd/CMakeLists.txt
@@ -6,7 +6,8 @@ IF (NOT HAVE_SSL)
MESSAGE(FATAL_ERROR "openssl library not found")
ENDIF (NOT HAVE_SSL)
-CHECK_INCLUDE_FILES("openssl/md5.h" HAVE_SSL)
+SET(CMAKE_REQUIRED_INCLUDES "openssl")
+CHECK_INCLUDE_FILES("md5.h" HAVE_SSL)
IF (NOT HAVE_SSL)
MESSAGE(FATAL_ERROR "openssl headers not found")
ENDIF (NOT HAVE_SSL)