summaryrefslogtreecommitdiff
path: root/accel-pptpd/CMakeLists.txt
diff options
context:
space:
mode:
authorKozlov Dmitry <dima@server>2010-09-14 15:56:31 +0400
committerKozlov Dmitry <dima@server>2010-09-14 16:05:10 +0400
commitd860a4beaf5f99d5045d03b931b4829426a2f7b0 (patch)
tree377f0cf851020786f5e40f70644a3dafbc63ce14 /accel-pptpd/CMakeLists.txt
parenta670641cc3c420bfd9026d3711501663aef88287 (diff)
downloadaccel-ppp-xebd-d860a4beaf5f99d5045d03b931b4829426a2f7b0.tar.gz
accel-ppp-xebd-d860a4beaf5f99d5045d03b931b4829426a2f7b0.zip
extra: implemented module 'pppd_compat' which starts pppd compatible scripts ip-up, ip-down,
and newly introduced - ip-change, when radius CoA request received, also this module manages pppd compatible radattr.pppX files core: implemented module 'sigchld' which handles SIGCHLD signal, waits child processes to terminate and manages pid terminate handlers
Diffstat (limited to 'accel-pptpd/CMakeLists.txt')
-rw-r--r--accel-pptpd/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/accel-pptpd/CMakeLists.txt b/accel-pptpd/CMakeLists.txt
index 1621e35..b27302c 100644
--- a/accel-pptpd/CMakeLists.txt
+++ b/accel-pptpd/CMakeLists.txt
@@ -10,6 +10,7 @@ ADD_SUBDIRECTORY(ctrl)
ADD_SUBDIRECTORY(auth)
ADD_SUBDIRECTORY(radius)
ADD_SUBDIRECTORY(logs)
+ADD_SUBDIRECTORY(extra)
ADD_EXECUTABLE(pptpd
ppp/ppp.c
@@ -30,7 +31,10 @@ ADD_EXECUTABLE(pptpd
iprange.c
ippool.c
-
+
+ utils.c
+ sigchld.c
+
log.c
main.c
)