summaryrefslogtreecommitdiff
path: root/accel-pptpd/CMakeLists.txt
diff options
context:
space:
mode:
authorKozlov Dmitry <dima@server>2010-08-23 13:36:50 +0400
committerKozlov Dmitry <dima@server>2010-08-23 18:32:37 +0400
commit76615aa33fb294f2fdfdee3e4687de94bb5efce9 (patch)
tree5ff166a087fdd349de42cca87326a85570af9a8f /accel-pptpd/CMakeLists.txt
parent1dbf2a2820c428b8ba8b04d6ec30c78f642cbfb3 (diff)
downloadaccel-ppp-xebd-76615aa33fb294f2fdfdee3e4687de94bb5efce9.tar.gz
accel-ppp-xebd-76615aa33fb294f2fdfdee3e4687de94bb5efce9.zip
implemented base IPCP module
implemented IP-Address configuration option
Diffstat (limited to 'accel-pptpd/CMakeLists.txt')
-rw-r--r--accel-pptpd/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/accel-pptpd/CMakeLists.txt b/accel-pptpd/CMakeLists.txt
index 2a038f1..452f914 100644
--- a/accel-pptpd/CMakeLists.txt
+++ b/accel-pptpd/CMakeLists.txt
@@ -11,15 +11,21 @@ ADD_EXECUTABLE(pptpd
log.c
ppp.c
ppp_fsm.c
+
ppp_lcp.c
lcp_opt_mru.c
lcp_opt_magic.c
lcp_opt_pcomp.c
lcp_opt_accomp.c
+
ppp_auth.c
+ auth_pap.c
+
ppp_ccp.c
ppp_ipcp.c
- auth_pap.c
+ ipcp_opt_ipaddr.c
+
pwdb.c
+ ipdb.c
)
TARGET_LINK_LIBRARIES(pptpd pthread triton)