summaryrefslogtreecommitdiff
path: root/accel-pptpd/extra/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'accel-pptpd/extra/CMakeLists.txt')
-rw-r--r--accel-pptpd/extra/CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/accel-pptpd/extra/CMakeLists.txt b/accel-pptpd/extra/CMakeLists.txt
index 600c861..9d58b8e 100644
--- a/accel-pptpd/extra/CMakeLists.txt
+++ b/accel-pptpd/extra/CMakeLists.txt
@@ -1,10 +1,14 @@
ADD_LIBRARY(pppd_compat SHARED pppd_compat.c)
ADD_LIBRARY(ippool SHARED ippool.c)
ADD_LIBRARY(sigchld SHARED sigchld.c)
-ADD_LIBRARY(shaper_tbf SHARED shaper_tbf.c)
-TARGET_LINK_LIBRARIES(shaper_tbf nl)
INSTALL(TARGETS pppd_compat ippool sigchld
LIBRARY DESTINATION usr/lib/accel-pptp
)
+IF (SHAPER)
+ ADD_LIBRARY(shaper_tbf SHARED shaper_tbf.c)
+ TARGET_LINK_LIBRARIES(shaper_tbf nl-route)
+ INSTALL(TARGETS shaper_tbf LIBRARY DESTINATION usr/lib/accel-pptp)
+ENDIF (SHAPER)
+