summaryrefslogtreecommitdiff
path: root/contrib/gentoo
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/gentoo')
-rw-r--r--contrib/gentoo/net-dialup/accel-pptp/accel-pptp-9999.ebuild10
-rwxr-xr-xcontrib/gentoo/net-dialup/accel-pptp/files/pptpd-init1
2 files changed, 6 insertions, 5 deletions
diff --git a/contrib/gentoo/net-dialup/accel-pptp/accel-pptp-9999.ebuild b/contrib/gentoo/net-dialup/accel-pptp/accel-pptp-9999.ebuild
index 7632da8..e926e29 100644
--- a/contrib/gentoo/net-dialup/accel-pptp/accel-pptp-9999.ebuild
+++ b/contrib/gentoo/net-dialup/accel-pptp/accel-pptp-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=2
-inherit git linux-mod cmake-utils
+inherit eutils git linux-mod cmake-utils
EGIT_REPO_URI="git://accel-pptp.git.sourceforge.net/gitroot/accel-pptp/accel-pptp"
@@ -33,12 +33,13 @@ MODULESD_PPTP_ALIASES=("net-pf-24 pptp")
PREFIX="/"
MODULE_NAMES="pptp(extra:${S}/driver/)"
-src_unpack() {
+src_unpack () {
git_src_unpack
+}
+
+src_prepare() {
sed -i -e "/mkdir/d" "${S}/accel-pptpd/CMakeLists.txt"
sed -i -e "/INSTALL/d" "${S}/driver/CMakeLists.txt"
-
- convert_to_m ${S}/driver/Makefile
}
src_configure() {
@@ -65,6 +66,7 @@ src_compile() {
cmake-utils_src_compile
cd ${S}/driver
+ #convert_to_m Makefile
linux-mod_src_compile || die "failed to build driver"
}
diff --git a/contrib/gentoo/net-dialup/accel-pptp/files/pptpd-init b/contrib/gentoo/net-dialup/accel-pptp/files/pptpd-init
index d8e2ee5..f9155b4 100755
--- a/contrib/gentoo/net-dialup/accel-pptp/files/pptpd-init
+++ b/contrib/gentoo/net-dialup/accel-pptp/files/pptpd-init
@@ -6,7 +6,6 @@ depend() {
start() {
ebegin "Starting accel-pptpd"
- modprobe pptp
start-stop-daemon --start --quiet --exec /usr/sbin/accel-pptpd -- -p /var/run/pptpd.pid ${PPTPD_OPTS}
eend $?
}