summaryrefslogtreecommitdiff
path: root/accel-cmd/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'accel-cmd/CMakeLists.txt')
-rw-r--r--accel-cmd/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/accel-cmd/CMakeLists.txt b/accel-cmd/CMakeLists.txt
new file mode 100644
index 0000000..4455c8d
--- /dev/null
+++ b/accel-cmd/CMakeLists.txt
@@ -0,0 +1,14 @@
+SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Wextra -D_GNU_SOURCE")
+
+ADD_DEFINITIONS(-DACCEL_PPP_VERSION="${ACCEL_PPP_VERSION}")
+
+ADD_EXECUTABLE(accel-cmd
+ accel_cmd.c
+)
+
+INSTALL(TARGETS accel-cmd
+ RUNTIME DESTINATION bin
+)
+INSTALL(FILES accel-cmd.1
+ DESTINATION share/man/man1
+)