summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorChristian Poessinger <christian@poessinger.com>2022-12-31 07:35:39 +0100
committerGitHub <noreply@github.com>2022-12-31 07:35:39 +0100
commitede589d61889ecafc767a9aa52da5327012867e5 (patch)
tree05939302892e1310c1b0855601369132618cce3c /debian
parent1b5bb6cb9424c09e09bbeec8314ccf4e9c83bd98 (diff)
parent0c8b53e6f7a94e914a7815328bbd16c0b3943d40 (diff)
downloadvyos-1x-ede589d61889ecafc767a9aa52da5327012867e5.tar.gz
vyos-1x-ede589d61889ecafc767a9aa52da5327012867e5.zip
Merge pull request #1731 from c-po/t578-container-backport
container: T578: backport podman from 1.4 development branch (equuleus)
Diffstat (limited to 'debian')
-rw-r--r--debian/control2
-rwxr-xr-xdebian/vyos-1x-smoketest.postinst10
2 files changed, 12 insertions, 0 deletions
diff --git a/debian/control b/debian/control
index 5100f326a..16cab3a88 100644
--- a/debian/control
+++ b/debian/control
@@ -93,6 +93,7 @@ Depends:
pciutils,
pdns-recursor,
pmacct (>= 1.6.0),
+ podman,
pppoe,
procps,
python3,
@@ -138,6 +139,7 @@ Depends:
traceroute,
tuned,
udp-broadcast-relay,
+ uidmap,
usb-modeswitch,
usbutils,
vyatta-bash,
diff --git a/debian/vyos-1x-smoketest.postinst b/debian/vyos-1x-smoketest.postinst
new file mode 100755
index 000000000..18612804c
--- /dev/null
+++ b/debian/vyos-1x-smoketest.postinst
@@ -0,0 +1,10 @@
+#!/bin/sh -e
+
+BUSYBOX_TAG="docker.io/library/busybox:stable"
+OUTPUT_PATH="/usr/share/vyos/busybox-stable.tar"
+
+if [[ -f $OUTPUT_PATH ]]; then
+ rm -f $OUTPUT_PATH
+fi
+
+skopeo copy --additional-tag "$BUSYBOX_TAG" "docker://$BUSYBOX_TAG" "docker-archive:/$OUTPUT_PATH"