summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorDaniil Baturin <daniil@baturin.org>2019-08-29 12:07:01 +0200
committerDaniil Baturin <daniil@baturin.org>2019-08-29 12:07:01 +0200
commitcfcba5223d566e0cd2fc64ae58dbf0670df261bc (patch)
tree8b67d5cffa86c1c9c679e5eefda728e0a8be8aa3 /debian
parentbb0c520a7a09516ce6f34c69c337ac463ee5d74c (diff)
downloadvyos-1x-cfcba5223d566e0cd2fc64ae58dbf0670df261bc.tar.gz
vyos-1x-cfcba5223d566e0cd2fc64ae58dbf0670df261bc.zip
T1598: fix the debian/rules to get vyos-hostsd installed.
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules5
1 files changed, 5 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index a24d0280a..cf4c00375 100755
--- a/debian/rules
+++ b/debian/rules
@@ -10,6 +10,7 @@ VYOS_OP_TMPL_DIR := /opt/vyatta/share/vyatta-op/templates
MIGRATION_SCRIPTS_DIR := /opt/vyatta/etc/config-migrate/migrate/
SYSTEM_SCRIPTS_DIR := usr/libexec/vyos/system
+SERVICES_DIR := usr/libexec/vyos/services
%:
dh $@ --with python3, --with quilt
@@ -53,6 +54,10 @@ override_dh_auto_install:
mkdir -p $(DIR)/$(SYSTEM_SCRIPTS_DIR)
cp -r src/system/* $(DIR)/$(SYSTEM_SCRIPTS_DIR)
+ # Install system services
+ mkdir -p $(DIR)/$(SERVICES_DIR)
+ cp -r src/services/* $(DIR)/$(SERVICES_DIR)
+
# Install configuration command definitions
mkdir -p $(DIR)/$(VYOS_CFG_TMPL_DIR)
cp -r templates-cfg/* $(DIR)/$(VYOS_CFG_TMPL_DIR)