summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorChristian Poessinger <christian@poessinger.com>2022-12-30 22:23:05 +0100
committerChristian Poessinger <christian@poessinger.com>2022-12-30 22:28:25 +0100
commit0c8b53e6f7a94e914a7815328bbd16c0b3943d40 (patch)
treeeba692b6f044b54db55fa079f3460b4ed920a38b /debian
parent4bab998b4e7fe6eca57a3fe9ffba2d2be8f123b2 (diff)
downloadvyos-1x-0c8b53e6f7a94e914a7815328bbd16c0b3943d40.tar.gz
vyos-1x-0c8b53e6f7a94e914a7815328bbd16c0b3943d40.zip
container: T578: backport podman from 1.4 development branch
Diffstat (limited to 'debian')
-rw-r--r--debian/control2
-rwxr-xr-xdebian/vyos-1x-smoketest.postinst10
2 files changed, 12 insertions, 0 deletions
diff --git a/debian/control b/debian/control
index 5100f326a..16cab3a88 100644
--- a/debian/control
+++ b/debian/control
@@ -93,6 +93,7 @@ Depends:
pciutils,
pdns-recursor,
pmacct (>= 1.6.0),
+ podman,
pppoe,
procps,
python3,
@@ -138,6 +139,7 @@ Depends:
traceroute,
tuned,
udp-broadcast-relay,
+ uidmap,
usb-modeswitch,
usbutils,
vyatta-bash,
diff --git a/debian/vyos-1x-smoketest.postinst b/debian/vyos-1x-smoketest.postinst
new file mode 100755
index 000000000..18612804c
--- /dev/null
+++ b/debian/vyos-1x-smoketest.postinst
@@ -0,0 +1,10 @@
+#!/bin/sh -e
+
+BUSYBOX_TAG="docker.io/library/busybox:stable"
+OUTPUT_PATH="/usr/share/vyos/busybox-stable.tar"
+
+if [[ -f $OUTPUT_PATH ]]; then
+ rm -f $OUTPUT_PATH
+fi
+
+skopeo copy --additional-tag "$BUSYBOX_TAG" "docker://$BUSYBOX_TAG" "docker-archive:/$OUTPUT_PATH"