summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules4
-rw-r--r--debian/vyos-1x-smoketest.install2
3 files changed, 8 insertions, 0 deletions
diff --git a/debian/control b/debian/control
index ebcfc6c43..cd05fa966 100644
--- a/debian/control
+++ b/debian/control
@@ -10,6 +10,7 @@ Build-Depends:
python3,
python3-coverage,
python3-lxml,
+ python3-netifaces,
python3-nose,
python3-setuptools,
python3-xmltodict,
@@ -65,6 +66,7 @@ Depends:
ntpdate,
ocserv,
openssh-server,
+ openssl,
openvpn,
openvpn-auth-ldap,
openvpn-auth-radius,
diff --git a/debian/rules b/debian/rules
index 6b982fd8e..a0cc7a99b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -97,6 +97,10 @@ override_dh_auto_install:
mkdir -p $(DIR)/$(VYOS_LIBEXEC_DIR)/tests/smoke/
cp -r smoketest/scripts/* $(DIR)/$(VYOS_LIBEXEC_DIR)/tests/smoke
+ # Install smoke test configs
+ mkdir -p $(DIR)/$(VYOS_LIBEXEC_DIR)/tests/config/
+ cp -r smoketest/configs/* $(DIR)/$(VYOS_LIBEXEC_DIR)/tests/config
+
# Install system programs
mkdir -p $(DIR)/$(VYOS_BIN_DIR)
cp -r smoketest/bin/* $(DIR)/$(VYOS_BIN_DIR)
diff --git a/debian/vyos-1x-smoketest.install b/debian/vyos-1x-smoketest.install
index fdf949557..3739763b9 100644
--- a/debian/vyos-1x-smoketest.install
+++ b/debian/vyos-1x-smoketest.install
@@ -1,2 +1,4 @@
usr/bin/vyos-smoketest
+usr/bin/vyos-configtest
usr/libexec/vyos/tests/smoke
+usr/libexec/vyos/tests/config