summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog12
-rw-r--r--debian/control3
-rwxr-xr-xdebian/rules5
3 files changed, 20 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 0f4183837..e8519e87a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,15 @@
+vyos-1x (1.2.0-1) unstable; urgency=medium
+
+ * T666, T616: new implementation of the VRRP CLI.
+
+ -- Daniil Baturin <daniil@baturin.org> Fri, 27 Jul 2018 10:25:52 +0200
+
+vyos-1x (1.0.6) unstable; urgency=medium
+
+ * T736: Rewrite remote logging (syslog) to XML/Python
+
+ -- hagbard <vyosdev@derith.de> Tue, 24 Jul 2018 10:59:25 -0700
+
vyos-1x (1.0.5) unstable; urgency=medium
* T606: Error in DNS Forwarder listen-on
diff --git a/debian/control b/debian/control
index 51f396604..c87e7452c 100644
--- a/debian/control
+++ b/debian/control
@@ -19,6 +19,8 @@ Depends: python3,
python3-netifaces,
python3-jinja2,
python3-pystache,
+ python3-psutil,
+ python3-tabulate,
ipaddrcheck,
tcpdump,
bmon,
@@ -33,6 +35,7 @@ Depends: python3,
iputils-arping,
libvyosconfig0,
beep,
+ keepalived (>=2.0.5),
${shlibs:Depends},
${misc:Depends}
Description: VyOS configuration scripts and data
diff --git a/debian/rules b/debian/rules
index d284471ec..15dfec551 100755
--- a/debian/rules
+++ b/debian/rules
@@ -9,6 +9,7 @@ VYOS_CFG_TMPL_DIR := /opt/vyatta/share/vyatta-cfg/templates
VYOS_OP_TMPL_DIR := /opt/vyatta/share/vyatta-op/templates
MIGRATION_SCRIPTS_DIR := /opt/vyatta/etc/config-migrate/migrate/
+SYSTEM_SCRIPTS_DIR := usr/libexec/vyos/system
%:
dh $@ --with python3, --with quilt
@@ -48,6 +49,10 @@ override_dh_auto_install:
mkdir -p $(DIR)/$(MIGRATION_SCRIPTS_DIR)
cp -r src/migration-scripts/* $(DIR)/$(MIGRATION_SCRIPTS_DIR)
+ # Install system scripts
+ mkdir -p $(DIR)/$(SYSTEM_SCRIPTS_DIR)
+ cp -r src/system/* $(DIR)/$(SYSTEM_SCRIPTS_DIR)
+
# Install configuration command definitions
mkdir -p $(DIR)/$(VYOS_CFG_TMPL_DIR)
cp -r templates-cfg/* $(DIR)/$(VYOS_CFG_TMPL_DIR)