summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/control9
-rwxr-xr-xdebian/rules11
2 files changed, 1 insertions, 19 deletions
diff --git a/debian/control b/debian/control
index ec08968c9..8cbad99d9 100644
--- a/debian/control
+++ b/debian/control
@@ -6,14 +6,8 @@ Build-Depends:
debhelper (>= 9),
dh-python,
fakeroot,
- gcc-multilib [amd64],
- clang [amd64],
+ gcc,
iproute2,
- llvm [amd64],
- libbpf-dev [amd64],
- libelf-dev (>= 0.2) [amd64],
- libpcap-dev [amd64],
- build-essential,
libvyosconfig0 (>= 0.0.7),
libzmq3-dev,
python3 (>= 3.10),
@@ -84,7 +78,6 @@ Depends:
lcdproc-extra-drivers,
libatomic1,
libauparse0,
- libbpf1 [amd64],
libcharon-extra-plugins (>=5.9),
libcharon-extauth-plugins (>=5.9),
libndp-tools,
diff --git a/debian/rules b/debian/rules
index 55e02fae6..e613f1e0a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -28,10 +28,6 @@ override_dh_gencontrol:
override_dh_auto_build:
make all
-ifeq ($(DEB_TARGET_ARCH),amd64)
- # Only build XDP on amd64 systems
- make vyxdp
-endif
override_dh_auto_install:
dh_auto_install
@@ -127,10 +123,3 @@ override_dh_auto_install:
# Install udev script
mkdir -p $(DIR)/usr/lib/udev
cp src/helpers/vyos_net_name $(DIR)/usr/lib/udev
-
-ifeq ($(DEB_TARGET_ARCH),amd64)
- # We only install XDP on amd64 systems
- mkdir -p $(DIR)/$(VYOS_DATA_DIR)/xdp
- cp -r src/xdp/xdp_prog_kern.o $(DIR)/$(VYOS_DATA_DIR)/xdp
- find src/xdp -perm /a+x -exec cp {} $(DIR)/$(VYOS_SBIN_DIR) \;
-endif