summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog14
-rw-r--r--debian/control22
-rwxr-xr-xdebian/rules16
3 files changed, 45 insertions, 7 deletions
diff --git a/debian/changelog b/debian/changelog
index 3db7c422e..0f4183837 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,17 @@
+vyos-1x (1.0.5) unstable; urgency=medium
+
+ * T606: Error in DNS Forwarder listen-on
+ * T608: Cannot configure broadcast-relay service
+
+ -- Christian Poessinger <christian@poessinger.com> Thu, 19 Apr 2018 21:16:28 +0200
+
+vyos-1x (1.0.4) unstable; urgency=medium
+
+ * T560: dns-forwarding: replace dnsmasq with pdns-recursor
+ * T588: Rewrite 'service dns forwarding' in new XML style format
+
+ -- Christian Poessinger <christian@poessinger.com> Sun, 15 Apr 2018 16:13:32 +0200
+
vyos-1x (1.0.3) unstable; urgency=medium
* T379: Add UDP broadcast relay support
diff --git a/debian/control b/debian/control
index a19cc80d4..c31c470e9 100644
--- a/debian/control
+++ b/debian/control
@@ -2,13 +2,27 @@ Source: vyos-1x
Section: contrib/net
Priority: extra
Maintainer: VyOS Package Maintainers <maintainers@vyos.net>
-Build-Depends: debhelper (>= 9), python3, python3-setuptools, quilt,
- python3-lxml
+Build-Depends: debhelper (>= 9),
+ quilt,
+ python3,
+ python3-setuptools,
+ quilt,
+ python3-lxml
Standards-Version: 3.9.6
Package: vyos-1x
Architecture: all
-Depends: python3, ${python3:Depends}, python3-netifaces,
- ${shlibs:Depends}, ${misc:Depends}
+Depends: python3,
+ ${python3:Depends},
+ python3-netifaces,
+ python3-jinja2,
+ python3-pystache,
+ ipaddrcheck,
+ tcpdump,
+ bmon,
+ hvinfo,
+ file,
+ ${shlibs:Depends},
+ ${misc:Depends}
Description: VyOS configuration scripts and data
VyOS configuration scripts, interface definitions, and everything
diff --git a/debian/rules b/debian/rules
index 5c3aab7f6..ed33706e4 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,26 +2,36 @@
DIR := debian/vyos-1x
VYOS_SBIN_DIR := opt/vyatta/sbin/
+VYOS_BIN_DIR := opt/vyatta/bin/
VYOS_LIBEXEC_DIR := opt/vyatta/libexec
VYOS_CFG_TMPL_DIR := /opt/vyatta/share/vyatta-cfg/templates
+VYOS_OP_TMPL_DIR := /opt/vyatta/share/vyatta-op/templates
%:
dh $@ --with python3, --with quilt
override_dh_auto_build:
- make
+ make all
override_dh_auto_install:
dh_install -pvyos-1x
cd python; python3 setup.py install --install-layout=deb --root ../$(DIR); cd ..
- # Install configuration scripts
+ # Install scripts
mkdir -p $(DIR)/$(VYOS_SBIN_DIR)
+ mkdir -p $(DIR)/$(VYOS_BIN_DIR)
cp -r src/conf-mode/* $(DIR)/$(VYOS_SBIN_DIR)
+ cp -r src/op-mode/* $(DIR)/$(VYOS_BIN_DIR)
# Install validators
mkdir -p $(DIR)/$(VYOS_LIBEXEC_DIR)/validators
cp -r src/validators/* $(DIR)/$(VYOS_LIBEXEC_DIR)/validators
+ # Install helper scripts
+ cp -r src/helpers/* $(DIR)/$(VYOS_LIBEXEC_DIR)/
+
mkdir -p $(DIR)/$(VYOS_CFG_TMPL_DIR)
- cp -r templates/* $(DIR)/$(VYOS_CFG_TMPL_DIR)
+ cp -r templates-cfg/* $(DIR)/$(VYOS_CFG_TMPL_DIR)
+
+ mkdir -p $(DIR)/$(VYOS_OP_TMPL_DIR)
+ cp -r templates-op/* $(DIR)/$(VYOS_OP_TMPL_DIR)