summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/control1
-rw-r--r--debian/vyos-1x.postinst7
2 files changed, 7 insertions, 1 deletions
diff --git a/debian/control b/debian/control
index c5a60f660..0c957cbef 100644
--- a/debian/control
+++ b/debian/control
@@ -21,7 +21,6 @@ Build-Depends:
python3-jinja2,
python3-psutil,
python3-setuptools,
- python3-sphinx,
quilt,
whois
Standards-Version: 3.9.6
diff --git a/debian/vyos-1x.postinst b/debian/vyos-1x.postinst
index 0e6e3c863..78e895d6e 100644
--- a/debian/vyos-1x.postinst
+++ b/debian/vyos-1x.postinst
@@ -194,3 +194,10 @@ systemctl enable vyos-config-cloud-init.service
# Update XML cache
python3 /usr/lib/python3/dist-packages/vyos/xml_ref/update_cache.py
+
+# Generate hardlinks for systemd units for multi VRF support
+# as softlinks will fail in systemd:
+# symlink target name type "ssh.service" does not match source, rejecting.
+if [ ! -f /lib/systemd/system/ssh@.service ]; then
+ ln /lib/systemd/system/ssh.service /lib/systemd/system/ssh@.service
+fi