summaryrefslogtreecommitdiff
path: root/debian.trunk
diff options
context:
space:
mode:
authorScott Moser <smoser@ubuntu.com>2011-02-04 16:58:24 -0500
committerScott Moser <smoser@ubuntu.com>2011-02-04 16:58:24 -0500
commit7077e1481ee22d99126ceb011b8819bd1a23487c (patch)
tree9a62b5b5d8296becf02197023850d80a502cd665 /debian.trunk
parent38b21ce3c0972d0659c4a4a9fb22640ff1d3f439 (diff)
downloadvyos-cloud-init-7077e1481ee22d99126ceb011b8819bd1a23487c.tar.gz
vyos-cloud-init-7077e1481ee22d99126ceb011b8819bd1a23487c.zip
add a debian.trunk dir and tools/bddeb to easily build a deb from here
Diffstat (limited to 'debian.trunk')
-rw-r--r--debian.trunk/changelog5
-rw-r--r--debian.trunk/compat1
-rw-r--r--debian.trunk/control15
-rw-r--r--debian.trunk/copyright51
-rw-r--r--debian.trunk/dirs5
-rw-r--r--debian.trunk/pycompat1
-rwxr-xr-xdebian.trunk/rules29
7 files changed, 107 insertions, 0 deletions
diff --git a/debian.trunk/changelog b/debian.trunk/changelog
new file mode 100644
index 00000000..33f97f28
--- /dev/null
+++ b/debian.trunk/changelog
@@ -0,0 +1,5 @@
+cloud-init (0.6.0) UNRELEASED; urgency=low
+
+ * build
+
+ -- Scott Moser <smoser@ubuntu.com> Tue, 01 Feb 2011 16:15:30 -0500
diff --git a/debian.trunk/compat b/debian.trunk/compat
new file mode 100644
index 00000000..7ed6ff82
--- /dev/null
+++ b/debian.trunk/compat
@@ -0,0 +1 @@
+5
diff --git a/debian.trunk/control b/debian.trunk/control
new file mode 100644
index 00000000..8e279aea
--- /dev/null
+++ b/debian.trunk/control
@@ -0,0 +1,15 @@
+Source: cloud-init
+Section: admin
+Priority: extra
+Maintainer: Scott Moser <smoser@ubuntu.com>
+Build-Depends: cdbs, debhelper (>= 5.0.38), python, python-central (>= 0.5.6)
+XS-Python-Version: all
+Standards-Version: 3.9.1
+
+Package: cloud-init
+Architecture: all
+Depends: python, procps, python-configobj, python-cheetah, python-yaml, python-software-properties, cloud-utils, ${python:Depends}, ${misc:Depends}
+XB-Python-Version: ${python:Versions}
+Description: Init scripts for cloud instances
+ Cloud instances need special scripts to run during initialisation
+ to retrieve and install ssh keys and to let the user run various scripts.
diff --git a/debian.trunk/copyright b/debian.trunk/copyright
new file mode 100644
index 00000000..dc993525
--- /dev/null
+++ b/debian.trunk/copyright
@@ -0,0 +1,51 @@
+Format-Specification: http://svn.debian.org/wsvn/dep/web/deps/dep5.mdwn?op=file&rev=135
+Name: cloud-init
+Maintainer: Scott Moser <scott.moser@canonical.com>
+Source: https://launchpad.net/cloud-init
+
+This package was debianized by Soren Hansen <soren@ubuntu.com> on
+Thu, 04 Sep 2008 12:49:15 +0200 as ec2-init. It was later renamed to
+cloud-utils by Scott Moser <scott.moser@canonical.com>
+
+Upstream Author: Scott Moser <smoser@canonical.com>
+ Soren Hansen <soren@canonical.com>
+ Chuck Short <chuck.short@canonical.com>
+
+Copyright: 2010, Canonical Ltd.
+License: GPL-3
+ This program is free software: you can redistribute it and/or modify
+ it under the terms of the GNU General Public License version 3, as
+ published by the Free Software Foundation.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+ The complete text of the GPL version 3 can be seen in
+ /usr/share/common-licenses/GPL-3.
+
+Files: cloudinit/boto_utils.py
+Copyright: 2006,2007, Mitch Garnaat http://garnaat.org/
+License: MIT
+ Permission is hereby granted, free of charge, to any person obtaining a
+ copy of this software and associated documentation files (the
+ "Software"), to deal in the Software without restriction, including
+ without limitation the rights to use, copy, modify, merge, publish, dis-
+ tribute, sublicense, and/or sell copies of the Software, and to permit
+ persons to whom the Software is furnished to do so, subject to the fol-
+ lowing conditions:
+
+ The above copyright notice and this permission notice shall be included
+ in all copies or substantial portions of the Software.
+
+ THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
+ OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABIL-
+ ITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT
+ SHALL THE AUTHOR BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
+ WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+ OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
+ IN THE SOFTWARE.
diff --git a/debian.trunk/dirs b/debian.trunk/dirs
new file mode 100644
index 00000000..f3de468d
--- /dev/null
+++ b/debian.trunk/dirs
@@ -0,0 +1,5 @@
+var/lib/cloud
+usr/bin
+etc/init
+usr/share/doc/cloud
+etc/cloud
diff --git a/debian.trunk/pycompat b/debian.trunk/pycompat
new file mode 100644
index 00000000..0cfbf088
--- /dev/null
+++ b/debian.trunk/pycompat
@@ -0,0 +1 @@
+2
diff --git a/debian.trunk/rules b/debian.trunk/rules
new file mode 100755
index 00000000..200b7abb
--- /dev/null
+++ b/debian.trunk/rules
@@ -0,0 +1,29 @@
+#!/usr/bin/make -f
+
+DEB_PYTHON_SYSTEM := pycentral
+export DH_PYCENTRAL=include-links
+
+binary-install/cloud-init::cloud-init-fixups
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/python-distutils.mk
+
+DEB_DH_INSTALL_SOURCEDIR := debian/tmp
+
+cloud-init-fixups:
+ for x in $(DEB_DESTDIR)/usr/bin/*.py; do mv "$$x" "$${x%.py}"; done
+ install -d $(DEB_DESTDIR)/etc/rsyslog.d
+ cp tools/21-cloudinit.conf $(DEB_DESTDIR)/etc/rsyslog.d/21-cloudinit.conf
+
+# You only need to run this immediately after checking out the package from
+# revision control.
+# http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=572204
+quilt-setup:
+ @[ ! -d .pc ] || { echo ".pc exists. remove it and re-run to start fresh"; exit 1; }
+ set -e; for patch in $$(quilt series | tac); do \
+ patch -p1 -R --no-backup-if-mismatch <"debian/patches/$$patch"; \
+ done
+ quilt push -a
+
+.PHONY: quilt-setup
+