summaryrefslogtreecommitdiff
path: root/debian/init
diff options
context:
space:
mode:
authorChuck Short <zulcss@ubuntu.com>2009-05-28 06:04:31 +0200
committerChuck Short <zulcss@ubuntu.com>2009-05-28 06:04:31 +0200
commitbb5711688e7f6b2abe4e82a5b5233194a323b99d (patch)
tree734ee82e43a33a79d87b059143eccf10095ae339 /debian/init
parentebfb2ed46dc72aa78e1477607ccf77b1f552fcf0 (diff)
downloadvyos-cloud-init-bb5711688e7f6b2abe4e82a5b5233194a323b99d.tar.gz
vyos-cloud-init-bb5711688e7f6b2abe4e82a5b5233194a323b99d.zip
* debian/init: Run update-motd regardless whether its a firstboot or not.
* debian/init: Fix comments (LP: #373057) * debian/control: Add update-motd as a depends. * ec2-set-defaults.py: Wait for network to become available. (LP: #308530)
Diffstat (limited to 'debian/init')
-rw-r--r--debian/init7
1 files changed, 5 insertions, 2 deletions
diff --git a/debian/init b/debian/init
index 3f982be5..0f0c3767 100644
--- a/debian/init
+++ b/debian/init
@@ -16,7 +16,7 @@ NAME=ec2-init
. /lib/lsb/init-functions
-if [ ! -d /var/run/ec2 ]; then
+if [ ! -d /var/ec2 ]; then
mkdir /var/ec2
fi
@@ -37,8 +37,11 @@ first_boot() {
ssh-keygen -l -f /etc/ssh/ssh_host_dsa_key.pub | logger -s -t "ec2"
echo "-----END SSH HOST KEY FINGERPRINTS-----" | logger -s -t "ec2"
echo "#############################################################" | logger -s -t "ec2"
- update-motd
+ /usr/sbin/update-motd
touch /var/ec2/.first-boot
+ else
+ log_daemon_msg "Running update-motd"
+ /usr/sbin/update-motd
fi
}