summaryrefslogtreecommitdiff
path: root/debian/init
diff options
context:
space:
mode:
authorChuck Short <zulcss@ubuntu.com>2009-04-06 23:04:48 +0100
committerBazaar Package Importer <jamesw@ubuntu.com>2009-04-06 23:04:48 +0100
commit6dddf16cb8dea2e1a96b3d613b81087df247fd3d (patch)
treeb8945a128e4eca03b25b1dd0d93368c797bd9a9c /debian/init
parent406eb2f8e235c7e24b7eeb1c044ef64741f0569b (diff)
downloadvyos-cloud-init-6dddf16cb8dea2e1a96b3d613b81087df247fd3d.tar.gz
vyos-cloud-init-6dddf16cb8dea2e1a96b3d613b81087df247fd3d.zip
* ec2-set-hostname.py:
- Use template for /etc/hosts creation. - Dont use public_hostname in /etc/hosts. (LP: #352745) * debian/control: - Add python-cheetah as a depends. * templates/sources.list.tmpl: - Update template. * debian/init: - Run the ec2-user-data script last so that the users get a stable system before running the user scripts.
Diffstat (limited to 'debian/init')
-rw-r--r--debian/init16
1 files changed, 8 insertions, 8 deletions
diff --git a/debian/init b/debian/init
index ea4f0acf..113d8700 100644
--- a/debian/init
+++ b/debian/init
@@ -38,14 +38,6 @@ case "$1" in
log_end_msg 1
fi
- log_daemon_msg "Running EC2 user data"
- if ec2-run-user-data 2>&1 | logger -t "user-data"
- then
- log_end_msg 0
- else
- log_end_msg 1
- fi
-
log_daemon_msg "Setting hostname to EC2 public_hostname"
if ec2-set-hostname 2> /dev/null
then
@@ -61,6 +53,14 @@ case "$1" in
log_end_msg 1
fi
+ log_daemon_msg "Running EC2 user data"
+ if ec2-run-user-data 2>&1 | logger -t "user-data"
+ then
+ log_end_msg 0
+ else
+ log_end_msg 1
+ fi
+
;;
stop)
exit 0