summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorChuck Short <zulcss@ubuntu.com>2009-02-09 19:12:09 +0000
committerBazaar Package Importer <jamesw@ubuntu.com>2009-02-09 19:12:09 +0000
commit4685dd287c9eea18dc18bac1260b7a1169271f78 (patch)
tree79738235d552663619932980d46f9a9e004aeb2e /debian/rules
parent40bc760f17a67700ad19b0d2250deec4e5e06954 (diff)
downloadvyos-cloud-init-4685dd287c9eea18dc18bac1260b7a1169271f78.tar.gz
vyos-cloud-init-4685dd287c9eea18dc18bac1260b7a1169271f78.zip
* ec2-set-apt-sources.py
- Determine the zone that the user is in and generate a /etc/apt/sources.list.d/ based on that. * debian/init: - Check to see if there is an /var/run/ec2 and create it if it doesnt exist. - Start ec2-set-apt-sources at first bootup. * debian/rules: - Install ec2-set-apt-sources. * debian/control: - Add python-configobj as a dependency. * debian/{install,dirs} - Create an /etc/ec2-init to read the configuration file and install it.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules2
1 files changed, 2 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index f3f8d30f..dbdd8253 100755
--- a/debian/rules
+++ b/debian/rules
@@ -7,6 +7,8 @@ DEB_UPDATE_RCD_PARAMS:= start 90 2 3 4 5 . stop 20 1 .
build/ec2-init::
install -d debian/tmp/usr/sbin
mkdir -p debian/tmp/var/ec2
+ mkdir -p debian/tmp/etc/ec2-init
install -m 775 ec2-fetch-credentials.py debian/tmp/usr/sbin/ec2-fetch-credentials
install -m 775 ec2-run-user-data.py debian/tmp/usr/sbin/ec2-run-user-data
install -m 755 ec2-set-hostname.py debian/tmp/usr/sbin/ec2-set-hostname
+ install -m 755 ec2-set-apt-sources.py debian/tmp/usr/sbin/ec2-set-apt-sources