summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorChuck Short <zulcss@ubuntu.com>2009-01-19 18:56:02 +0000
committerBazaar Package Importer <jamesw@ubuntu.com>2009-01-19 18:56:02 +0000
commit2be0869fc100cc12f304192552d799e3232f6d2e (patch)
tree2628504bc76a623d443a9cff7a7c8375d4e3400b /debian
parentb7d4c2c4a45c83d7e4a0c5ca7271c4ae13cd1f84 (diff)
downloadvyos-cloud-init-2be0869fc100cc12f304192552d799e3232f6d2e.tar.gz
vyos-cloud-init-2be0869fc100cc12f304192552d799e3232f6d2e.zip
ec2-run-user-data: Fix python error when writing a file to the disk.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog6
-rw-r--r--debian/init12
-rwxr-xr-xdebian/rules1
3 files changed, 16 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index ff4199bd..e87676e7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+ec2-init (0.3) jaunty; urgency=low
+
+ * ec2-run-user-data: Fix python error when writing a file to the disk.
+
+ -- Chuck Short <zulcss@ubuntu.com> Thu, 15 Jan 2009 11:49:08 -0500
+
ec2-init (0.2) jaunty; urgency=low
* debian/init: Run fetch-credentials before anything else.
diff --git a/debian/init b/debian/init
index e1deee83..24db3845 100644
--- a/debian/init
+++ b/debian/init
@@ -27,11 +27,17 @@ case "$1" in
fi
log_daemon_msg "Running EC2 user data"
- if ec2-run-user-data 2> /dev/null
+ if [ -f /var/ec2/.already_ran ]
then
- log_end_msg 0
+ echo "Already ran";
else
- log_end_msg 1
+ if ec2-run-user-data 2> /dev/null
+ then
+ log_end_msg 0
+ touch /var/ec2/.already_ran
+ else
+ log_end_msg 1
+ fi
fi
if pgrep nash-hotplug > /dev/null
diff --git a/debian/rules b/debian/rules
index e5f924ef..b3812f7e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,6 +6,7 @@ DEB_UPDATE_RCD_PARAMS:=start 90 S .
build/ec2-init::
install -d debian/tmp/usr/sbin
+ mkdir -p debian/tmp/var/ec2
install -m 775 ec2-fetch-credentials.py debian/tmp/usr/sbin/ec2-fetch-credentials
install -m 775 ec2-run-user-data.py debian/tmp/usr/sbin/ec2-run-user-data
install -m 755 ec2-set-hostname.py debian/tmp/usr/sbin/ec2-set-hostname