summaryrefslogtreecommitdiff
path: root/packages/debian/rules
diff options
context:
space:
mode:
authorScott Moser <smoser@ubuntu.com>2015-02-10 20:32:32 +0000
committerScott Moser <smoser@ubuntu.com>2015-02-10 20:32:32 +0000
commita4a6702758cf60ecb8742d78e576733dbbdbb9a0 (patch)
treeb5f23eff4f9c7e87fe2b09cdbe1d1b38aa518929 /packages/debian/rules
parent888db3e6bb9076973d2f6a73e0c4f691caa89603 (diff)
downloadvyos-cloud-init-a4a6702758cf60ecb8742d78e576733dbbdbb9a0.tar.gz
vyos-cloud-init-a4a6702758cf60ecb8742d78e576733dbbdbb9a0.zip
make bddeb work with python3 or python2
painful, and not perfect, but at this point the output builds on a vivid system python2 (bddeb --python2) or python3. * remove use of cheetah by bddeb in favor of builtin renderer * add '--python2' flag to bddeb and knowledge of python 2 and python3 package names. * read-dependencies can now read test-requirements also. * differenciate from build-requirements and runtime requirements.
Diffstat (limited to 'packages/debian/rules')
-rwxr-xr-xpackages/debian/rules17
1 files changed, 0 insertions, 17 deletions
diff --git a/packages/debian/rules b/packages/debian/rules
deleted file mode 100755
index 9e0c5ddb..00000000
--- a/packages/debian/rules
+++ /dev/null
@@ -1,17 +0,0 @@
-#!/usr/bin/make -f
-
-INIT_SYSTEM ?= upstart,systemd
-export PYBUILD_INSTALL_ARGS=--init-system=$(INIT_SYSTEM)
-
-%:
- dh $@ --with python2,systemd --buildsystem pybuild
-
-override_dh_install:
- dh_install
- install -d debian/cloud-init/etc/rsyslog.d
- cp tools/21-cloudinit.conf debian/cloud-init/etc/rsyslog.d/21-cloudinit.conf
-
-override_dh_auto_test:
- # Becuase setup tools didn't copy data...
- cp -r tests/data .pybuild/pythonX.Y_2.7/build/tests
- http_proxy= dh_auto_test -- --test-nose