summaryrefslogtreecommitdiff
path: root/packages/pkg-deps.json
diff options
context:
space:
mode:
authorParide Legovini <paride.legovini@canonical.com>2020-05-02 02:57:24 +0200
committerGitHub <noreply@github.com>2020-05-01 18:57:24 -0600
commit4d2684848722cb2d469ad4fa60999bf81cf7056e (patch)
tree2246e875479392fb7e38ee16bbe0815df7d89308 /packages/pkg-deps.json
parent70dbccbbb27f7cc3f2decd692d41403f0d745c62 (diff)
downloadvyos-cloud-init-4d2684848722cb2d469ad4fa60999bf81cf7056e.tar.gz
vyos-cloud-init-4d2684848722cb2d469ad4fa60999bf81cf7056e.zip
Adapt the package building scripts to use Python 3 (#231)
Since upstream cloud-init has dropped python2 support, adapt remaining package build scripts and tools to python3 only Changes: * Do not template debian/rules as python3 is the only supported version * Drop six from requirements.txt * Makefile: drop everything related to Python 2 * run-container: install the CI deps only on ubuntu|debian * read-version: update the shebang to use Python 3 * brpm: read_dependencies(): drop unused argument * read-dependencies: switch to Py3 and drop the --python-version option * pkg-deps.json: drop the Python version field and update the redhat deps * pkg-deps.json: drop the unittest2 and contextlib2 renames * Update RPM the spec file to use Python 3 when building the RPM * bddeb: drop support for Python 2
Diffstat (limited to 'packages/pkg-deps.json')
-rw-r--r--packages/pkg-deps.json55
1 files changed, 17 insertions, 38 deletions
diff --git a/packages/pkg-deps.json b/packages/pkg-deps.json
index f02e8348..80028396 100644
--- a/packages/pkg-deps.json
+++ b/packages/pkg-deps.json
@@ -6,49 +6,31 @@
"dh-systemd"
],
"renames" : {
- "pyyaml" : {
- "2" : "python-yaml",
- "3" : "python3-yaml"
- },
- "pyserial" : {
- "2" : "python-serial",
- "3" : "python3-serial"
- }
+ "pyyaml" : "python3-yaml",
+ "pyserial" : "python3-serial"
},
"requires" : [
"procps"
]
},
+ "centos" : {
+ "build-requires" : [
+ "python3-devel"
+ ],
+ "requires" : [
+ "e2fsprogs",
+ "iproute",
+ "net-tools",
+ "procps",
+ "rsyslog",
+ "shadow-utils",
+ "sudo"
+ ]
+ },
"redhat" : {
"build-requires" : [
- "python-devel",
- "python-setuptools"
+ "python3-devel"
],
- "renames" : {
- "jinja2" : {
- "3" : "python36-jinja2"
- },
- "jsonschema" : {
- "3" : "python36-jsonschema"
- },
- "pyflakes" : {
- "2" : "pyflakes",
- "3" : "python36-pyflakes"
- },
- "pyyaml" : {
- "2" : "PyYAML",
- "3" : "python36-PyYAML"
- },
- "pyserial" : {
- "2" : "pyserial"
- },
- "pytest": {
- "3": "python36-pytest"
- },
- "requests" : {
- "3" : "python36-requests"
- }
- },
"requires" : [
"e2fsprogs",
"iproute",
@@ -61,9 +43,6 @@
},
"suse" : {
"renames" : {
- "pyyaml" : {
- "2" : "python-yaml"
- }
},
"build-requires" : [
"fdupes",