diff options
author | Robert Schweikert <rjschwei@suse.com> | 2017-09-21 08:07:28 -0400 |
---|---|---|
committer | Scott Moser <smoser@brickies.net> | 2017-09-21 13:05:21 -0400 |
commit | 243ec59fb62a8710430f9ba1e2490ee964c1abc0 (patch) | |
tree | 5162501e57663e97ddb4e9f40e1a98bbec628a82 /setup.py | |
parent | 27613443139578dd1b968d1f5f953bd2bc6245a4 (diff) | |
download | vyos-cloud-init-243ec59fb62a8710430f9ba1e2490ee964c1abc0.tar.gz vyos-cloud-init-243ec59fb62a8710430f9ba1e2490ee964c1abc0.zip |
suse: Copy sysvinit files from redhat with slight changes.
Here we commit the SuSE provided sysvinit scripts. They are very similar
to those in redhat/ directory. They differ in small but important ways.
Rather than build a template system here we will just accept the copy
and paste. sysvinit in both RedHat and SuSE is EOL, so we do not
expect any real maintenance cost here.
LP: #1718649
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 2 |
1 files changed, 2 insertions, 0 deletions
@@ -121,6 +121,7 @@ INITSYS_FILES = { 'sysvinit_freebsd': [f for f in glob('sysvinit/freebsd/*') if is_f(f)], 'sysvinit_deb': [f for f in glob('sysvinit/debian/*') if is_f(f)], 'sysvinit_openrc': [f for f in glob('sysvinit/gentoo/*') if is_f(f)], + 'sysvinit_suse': [f for f in glob('sysvinit/suse/*') if is_f(f)], 'systemd': [render_tmpl(f) for f in (glob('systemd/*.tmpl') + glob('systemd/*.service') + @@ -133,6 +134,7 @@ INITSYS_ROOTS = { 'sysvinit_freebsd': 'usr/local/etc/rc.d', 'sysvinit_deb': 'etc/init.d', 'sysvinit_openrc': 'etc/init.d', + 'sysvinit_suse': 'etc/init.d', 'systemd': pkg_config_read('systemd', 'systemdsystemunitdir'), 'systemd.generators': pkg_config_read('systemd', 'systemdsystemgeneratordir'), |