diff options
author | Scott Moser <smoser@ubuntu.com> | 2016-06-20 22:38:26 -0400 |
---|---|---|
committer | Scott Moser <smoser@ubuntu.com> | 2016-06-20 22:38:26 -0400 |
commit | b0ea6e5a2c1c26b8faf1dc8303feebb00344e537 (patch) | |
tree | 1ec50e5f8c07ab1c7b4e206a5d0c7dca0858b640 /setup.py | |
parent | fe6919dcd37c6c1ecd371e5eb20b605ab20a6420 (diff) | |
parent | 776b0cfe847f531d8d5a235f52673c3da1f06064 (diff) | |
download | vyos-cloud-init-b0ea6e5a2c1c26b8faf1dc8303feebb00344e537.tar.gz vyos-cloud-init-b0ea6e5a2c1c26b8faf1dc8303feebb00344e537.zip |
merge with trunk.
test runs to the point where it did, think I got most of the changes
incorporated.
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 9 |
1 files changed, 6 insertions, 3 deletions
@@ -196,7 +196,6 @@ requirements = read_requires() if sys.version_info < (3,): requirements.append('cheetah') - setuptools.setup( name='cloud-init', version=get_version(), @@ -205,10 +204,14 @@ setuptools.setup( author_email='scott.moser@canonical.com', url='http://launchpad.net/cloud-init/', packages=setuptools.find_packages(exclude=['tests']), - scripts=['bin/cloud-init', - 'tools/cloud-init-per'], + scripts=['tools/cloud-init-per'], license='GPLv3', data_files=data_files, install_requires=requirements, cmdclass=cmdclass, + entry_points={ + 'console_scripts': [ + 'cloud-init = cloudinit.cmd.main:main' + ], + } ) |