diff options
author | Chad Smith <chad.smith@canonical.com> | 2017-07-28 14:28:47 -0600 |
---|---|---|
committer | Chad Smith <chad.smith@canonical.com> | 2017-07-28 14:28:47 -0600 |
commit | e586fe35a692b7519000005c8024ebd2bcbc82e0 (patch) | |
tree | b29b6a5a1a5536ede273a131c55241b191fc45e2 /setup.py | |
parent | 664a22021ce278dc4120a5737b21bf6fe5448166 (diff) | |
download | vyos-cloud-init-e586fe35a692b7519000005c8024ebd2bcbc82e0.tar.gz vyos-cloud-init-e586fe35a692b7519000005c8024ebd2bcbc82e0.zip |
cloudinit.net: add initialize_network_device function and tests
This is not yet called, but will be called in a subsequent Ec2-related branch to manually initialize a network interface with the responses using dhcp discovery without any dhcp-script side-effects. The functionality has been tested on Ec2 ubuntu and CentOS vms to ensure that network interface initialization works in both OS-types.
Since there was poor unit test coverage for the cloudinit.net.__init__ module, this branch adds a bunch of coverage to the functions in cloudinit.net.__init. We can also now have unit tests local to the cloudinit modules. The benefits of having unittests under cloudinit module:
- Proximity of unittest to cloudinit module makes it easier for ongoing devs to know where to augment unit tests. The tests.unittest directory is organizated such that it
- Allows for 1 to 1 name mapping module -> tests/test_module.py
- Improved test and module isolation, if we find unit tests have to import from a number of modules besides the module under test, it will better prompt resturcturing of the module.
This also branch touches:
- tox.ini to run unit tests found in cloudinit as well as include all test-requirements for pylint since we now have unit tests living within cloudinit package
- setup.py to exclude any test modules under cloudinit when packaging
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 2 |
1 files changed, 1 insertions, 1 deletions
@@ -240,7 +240,7 @@ setuptools.setup( author='Scott Moser', author_email='scott.moser@canonical.com', url='http://launchpad.net/cloud-init/', - packages=setuptools.find_packages(exclude=['tests']), + packages=setuptools.find_packages(exclude=['tests.*', '*.tests', 'tests']), scripts=['tools/cloud-init-per'], license='Dual-licensed under GPLv3 or Apache 2.0', data_files=data_files, |