summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorScott Moser <smoser@nelson>2010-01-06 12:39:47 -0500
committerScott Moser <smoser@nelson>2010-01-06 12:39:47 -0500
commitca3cafbb65655bf0de40e8a44b608932694a5594 (patch)
treefe0360e5af37d5b6a22055ed87c63db86230525e /setup.py
parent86b6aad19f3796402dbc2f6e90a47081e8b309a0 (diff)
downloadvyos-cloud-init-ca3cafbb65655bf0de40e8a44b608932694a5594.tar.gz
vyos-cloud-init-ca3cafbb65655bf0de40e8a44b608932694a5594.zip
add cloud-init-run-module and ec2init/execute.py
cloud-init-run-module handles some boilerplate code for running items on a 'frequency'. It has the following usefulness - a config module can be put into ec2init dir and implement a 'run' method that takes a list of arguments and the path to a config file - it handles invoking module.run() only at a given frequency This is similar to karmic's ec2init's "run_once_ever" or run_once_per_ami execute.py is an example module that executes the arguments given to it An example usage in an upstart job would be with a 'exec' line like: exec cloud-init-run-module once_per_ami clean-core execute rm /var/run/core The above would then run the command 'rm /var/run/core' only once
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index aaa7cbeb..0f86cb54 100755
--- a/setup.py
+++ b/setup.py
@@ -36,7 +36,9 @@ setup(name='EC2-init',
'ec2-set-hostname.py',
'ec2-wait-for-meta-data-service.py',
'ec2-init.py',
- 'ec2-is-compat-env'],
+ 'ec2-is-compat-env',
+ 'cloud-init-run-module.py'
+ ],
data_files=[('/etc/ec2-init', ['ec2-config.cfg']),
('/etc/ec2-init/templates', glob('templates/*')),
('/etc/init', ['ec2init.conf']),