summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorRoberto Berto <roberto.berto@gmail.com>2023-11-21 17:07:23 -0300
committerRoberto Berto <roberto.berto@gmail.com>2023-11-21 17:07:23 -0300
commit6923921dc77865ae43586a2667b747f383dc0fb3 (patch)
treef86b9e6bf9b2a916562e9ef0e2efd1fa6f6a673b /pyproject.toml
parent70dec1d1ac1c91c04402f571b8d42051da417cb1 (diff)
downloadpyvyos-6923921dc77865ae43586a2667b747f383dc0fb3.tar.gz
pyvyos-6923921dc77865ae43586a2667b747f383dc0fb3.zip
fixed pyproject
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml40
1 files changed, 33 insertions, 7 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 355a077..ef4c9c8 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,17 +1,43 @@
[build-system]
-requires = ["setuptools", "wheel"]
-build-backend = "setuptools.build_meta"
+requires = ["hatchling"]
+build-backend = "hatchling.build"
-[tool.poetry]
+[project]
name = "vyapi"
version = "0.1.1"
+authors = [
+ { name="Roberto Berto", email="roberto.berto@gmail.com" },
+]
+description = "Python SDK for interacting with VyOS API"
+readme = "README.md"
+requires-python = ">=3.8"
+classifiers = [
+ "Programming Language :: Python :: 3",
+ "License :: OSI Approved :: MIT License",
+ "Operating System :: OS Independent",
+]
+
+[project.urls]
+Homepage = "https://github.com/gravscale/vyapi"
+Issues = "https://github.com/gravscale/vyapi/issues"
+
+[tool.hatch.metadata]
+dependencies = [
+ "requests>=2.25.1,<3.0",
+ "python-dotenv>=1.0.0,<2.0"
+]
+dev-dependencies = [
+ "pytest>=6.2.2,<7.0"
+]
+
+[tool.poetry]
+name = "vyapi"
description = "Python SDK for interacting with VyOS API"
authors = ["Roberto Berto <roberto.berto@gmail.com>"]
+version = "0.1.1"
[tool.poetry.dependencies]
-python = ">=3.8,<4.0"
-requests = "^2.25.1"
+python = ">=3.8"
+requests = "^2.31.0"
python-dotenv = "^1.0.0"
-[tool.poetry.dev-dependencies]
-pytest = "^6.2.2"