summaryrefslogtreecommitdiff
path: root/src/helpers/Makefile.am
diff options
context:
space:
mode:
authorPablo Neira Ayuso <pablo@netfilter.org>2012-05-15 01:51:29 +0200
committerPablo Neira Ayuso <pablo@netfilter.org>2012-05-28 12:34:59 +0200
commite96bfcd1b9f79cb3642b365a584359b1672f2ac0 (patch)
tree48b625978164f802fd1a99bdf49a2e7140f6dc5d /src/helpers/Makefile.am
parente47233151ca5098b268281329b119a398918d75f (diff)
downloadconntrack-tools-e96bfcd1b9f79cb3642b365a584359b1672f2ac0.tar.gz
conntrack-tools-e96bfcd1b9f79cb3642b365a584359b1672f2ac0.zip
conntrackd: add cthelper infrastructure (+ example FTP helper)
This patch adds the user-space helper infrastructure. It also contains the implementation of the FTP helper in user-space. There's one example file that you can use to configure conntrackd as user-space connection tracking helper under: doc/helper/conntrackd.conf Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
Diffstat (limited to 'src/helpers/Makefile.am')
-rw-r--r--src/helpers/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/helpers/Makefile.am b/src/helpers/Makefile.am
new file mode 100644
index 0000000..2c9d63b
--- /dev/null
+++ b/src/helpers/Makefile.am
@@ -0,0 +1,9 @@
+include $(top_srcdir)/Make_global.am
+
+pkglib_LTLIBRARIES = ct_helper_ftp.la
+
+ct_helper_ftp_la_SOURCES = ftp.c
+ct_helper_ftp_la_LDFLAGS = -avoid-version -module $(LIBNETFILTER_CONNTRACK_LIBS)
+ct_helper_ftp_la_CFLAGS = $(AM_CFLAGS) $(LIBNETFILTER_CONNTRACK_CFLAGS)
+
+