summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules88
1 files changed, 88 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..11a1b34
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,88 @@
+#!/usr/bin/make -f
+# -*- mode: makefile; coding: utf-8 -*-
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+
+CFLAGS = -g
+
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ CFLAGS += -O0
+else
+ CFLAGS += -O2 -fno-strict-aliasing
+endif
+
+# fix "read_config_lex.c:4451: error: 'input' defined but not used"
+CFLAGS += -DYY_NO_INPUT
+
+build: debian/stamp-build
+debian/stamp-build:
+ dh_testdir
+ autoreconf -i
+ # ./configure
+ CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
+ --disable-dependency-tracking \
+ --prefix=/usr
+
+ # Build libnetfilter-conntrack
+ $(MAKE)
+
+ touch $@
+
+clean: clean1
+clean1:
+ dh_testdir
+ dh_testroot
+ rm -f debian/stamp-*
+
+ [ ! -f Makefile ] || $(MAKE) distclean
+
+ dh_clean
+
+install: debian/stamp-install
+debian/stamp-install: debian/stamp-build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ $(MAKE) DESTDIR=`pwd`/debian/tmp install
+
+ touch $@
+
+
+# Build architecture-independent files here.
+binary-indep:
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir -a
+ dh_testroot -a
+ dh_installdocs -a -A AUTHORS
+ dh_installchangelogs -a
+ dh_installlogrotate -a
+ dh_installinit -a
+ dh_install -a -X.svn
+ dh_link -a
+ dh_strip -a
+ dh_compress -a
+ dh_fixperms -a
+ dh_installdeb -a
+ dh_shlibdeps -av
+ if [ -f "../.VYOS_DEV_BUILD" ]; then \
+ dh_gencontrol -- -v999.dev; \
+ else \
+ dh_gencontrol; \
+ fi
+ dh_md5sums -a
+ dh_builddeb -a
+
+source diff:
+ @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install \
+ clean1