summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog1
-rw-r--r--debian/patches/00list3
-rw-r--r--debian/patches/large-integer-gcc43.dpatch15
-rw-r--r--debian/patches/printf-time-long.dpatch17
-rw-r--r--debian/patches/unused-input-gcc43.dpatch14
-rwxr-xr-xdebian/rules7
6 files changed, 3 insertions, 54 deletions
diff --git a/debian/changelog b/debian/changelog
index 669d579..d6ffa50 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,7 @@
conntrack (1:0.9.7-1) UNRELEASED; urgency=low
* new upstream release
+ - dropped all patches because they have been merged by upstream
-- Max Kellermann <max@duempel.org> Mon, 02 Jun 2008 16:26:41 +0200
diff --git a/debian/patches/00list b/debian/patches/00list
deleted file mode 100644
index 56317ab..0000000
--- a/debian/patches/00list
+++ /dev/null
@@ -1,3 +0,0 @@
-large-integer-gcc43.dpatch
-unused-input-gcc43.dpatch
-printf-time-long.dpatch
diff --git a/debian/patches/large-integer-gcc43.dpatch b/debian/patches/large-integer-gcc43.dpatch
deleted file mode 100644
index 3aec6d7..0000000
--- a/debian/patches/large-integer-gcc43.dpatch
+++ /dev/null
@@ -1,15 +0,0 @@
-#! /bin/sh /usr/share/dpatch/dpatch-run
-## DP: Fix Debian bug #472812: "conntrack.c:302: error: large integer
-## DP: implicitly truncated to unsigned type"
-
---- conntrack/src/conntrack.c
-+++ conntrack/src/conntrack.c
-@@ -299,7 +299,7 @@
- { CT_CREATE, ETIME, "conntrack has expired" },
- { EXP_CREATE, ENOENT, "master conntrack not found" },
- { EXP_CREATE, EINVAL, "invalid parameters" },
-- { ~0UL, EPERM, "sorry, you must be root or get "
-+ { ~0U, EPERM, "sorry, you must be root or get "
- "CAP_NET_ADMIN capability to do this"}
- };
-
diff --git a/debian/patches/printf-time-long.dpatch b/debian/patches/printf-time-long.dpatch
deleted file mode 100644
index 3beea9d..0000000
--- a/debian/patches/printf-time-long.dpatch
+++ /dev/null
@@ -1,17 +0,0 @@
-#! /bin/sh /usr/share/dpatch/dpatch-run
-## DP: Fix compilation warning (error) on SPARC, where timeval
-## DP: attributes don't seem to fit "%ld". Also format them as unsigned
-## DP: numbers.
-
---- conntrack-tools/src/conntrack.c
-+++ conntrack-tools/src/conntrack.c
-@@ -597,7 +597,8 @@
- if (!(output_mask & _O_XML)) {
- struct timeval tv;
- gettimeofday(&tv, NULL);
-- printf("[%-8ld.%-6ld]\t", tv.tv_sec, tv.tv_usec);
-+ printf("[%-8lu.%-6lu]\t", (unsigned long)tv.tv_sec,
-+ (unsigned long)tv.tv_usec);
- } else
- output_flags |= NFCT_OF_TIME;
- }
diff --git a/debian/patches/unused-input-gcc43.dpatch b/debian/patches/unused-input-gcc43.dpatch
deleted file mode 100644
index 66994d8..0000000
--- a/debian/patches/unused-input-gcc43.dpatch
+++ /dev/null
@@ -1,14 +0,0 @@
-#! /bin/sh /usr/share/dpatch/dpatch-run
-## DP: Fix Debian bug #474768: "read_config_lex.c:4451: error: 'input'
-## DP: defined but not used" (patch by Thiemo Seufer)
-
---- conntrack-0.9.6.original/src/read_config_lex.l 2008-03-08 11:25:30.000000000 +0000
-+++ conntrack-0.9.6/src/read_config_lex.l 2008-04-07 17:47:53.000000000 +0100
-@@ -23,6 +23,7 @@
- %}
-
- %option yylineno
-+%option noinput
- %option nounput
-
- ws [ \t]+
diff --git a/debian/rules b/debian/rules
index 3693317..5a173a8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -18,11 +18,8 @@ endif
# fix "read_config_lex.c:4451: error: 'input' defined but not used"
CFLAGS += -DYY_NO_INPUT
-DPATCH_STAMPFN = debian/stamp-patch
-include /usr/share/dpatch/dpatch.make
-
build: debian/stamp-build
-debian/stamp-build: $(DPATCH_STAMPFN)
+debian/stamp-build:
dh_testdir
# ./configure
@@ -35,7 +32,7 @@ debian/stamp-build: $(DPATCH_STAMPFN)
touch $@
-clean: unpatch
+clean:
dh_testdir
dh_testroot
rm -f debian/stamp-*