summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules14
1 files changed, 8 insertions, 6 deletions
diff --git a/debian/rules b/debian/rules
index 08a2fd4..816ada0 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,10 +1,12 @@
#!/usr/bin/make -f
-DEB_DH_GENCONTROL_ARGS_ALL = $(shell if [ -f "../.VYATTA_DEV_BUILD" ]; then \
- echo "-- -v999.dev"; fi)
-
-pre-build::
- rm -f debian/files
-
%:
dh $@
+
+override_dh_gencontrol:
+ if [ -f "../.VYATTA_DEV_BUILD" ]; then \
+ dh_gencontrol -- -v999.dev; \
+ else \
+ dh_gencontrol; \
+ fi
+