summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog20
-rw-r--r--debian/initramfs-tools.postinst8
2 files changed, 27 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 06292ff..38ec69f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,23 @@
+initramfs-tools (0.25) breezy; urgency=low
+
+ "If there was less sympathy in the world, there would be less
+ trouble in the world."
+ - Oscar Wilde
+
+ * init: Module the /dev tmpfs earlier. Make /dev/console, and
+ /dev/null on it at the beginning, just in case.
+
+ * debian/initramfs-tools.postinst: When copying the modules file over
+ from initrd-tools installations, filter out ext2, ext3, ide-generic
+ and ide-disk. These are leftovers from Warty.
+ (Ubuntu #14242)
+
+ * hooks/udev: New File (Ubuntu #12915)
+
+ * init: panic if ${init} doesn't exist on the target filesystem.
+
+ -- Jeff Bailey <jbailey@ubuntu.com> Thu, 1 Sep 2005 00:13:47 -0400
+
initramfs-tools (0.24) breezy; urgency=low
"Experience is simply the name we give out mistakes."
diff --git a/debian/initramfs-tools.postinst b/debian/initramfs-tools.postinst
index 6e61803..7d4eff6 100644
--- a/debian/initramfs-tools.postinst
+++ b/debian/initramfs-tools.postinst
@@ -15,7 +15,13 @@ if [ "$1" = configure ]; then
if [ -e /etc/mkinitrd/modules ]; then
cp /etc/mkinitrd/modules /etc/mkinitramfs
- sed -i -e 's/mkinitrd/mkinitramfs/g' /etc/mkinitramfs/modules
+ sed -i \
+ -e 's/mkinitrd/mkinitramfs/g' \
+ -e '/^ide-generic/d' \
+ -e '/^ide-disk/d' \
+ -e '/^ext2/d' \
+ -e '/^ext3/d' \
+ /etc/mkinitramfs/modules
fi
if [ -e ${RESUME} ]; then