summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDaniil Baturin <daniil@vyos.io>2024-01-04 13:38:37 -0500
committerDaniil Baturin <daniil@vyos.io>2024-01-04 13:38:37 -0500
commit23e0eda853a9bfa42a2fa0d50b31eea874a01a9c (patch)
treeba5e579ed670d0275fea996b0284b3a74da78f28 /src/Makefile.am
parent346aedbcd2257512208195bb165cc857e2907922 (diff)
downloadipaddrcheck-23e0eda853a9bfa42a2fa0d50b31eea874a01a9c.tar.gz
ipaddrcheck-23e0eda853a9bfa42a2fa0d50b31eea874a01a9c.zip
Add --range-prefix-length option
to require the range boundaries to lie within the same subnet of a given size
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 6098ae5..1c43bae 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,4 +1,4 @@
-AM_CFLAGS = --pedantic -Wall -Werror -std=c99 -O2
+AM_CFLAGS = --pedantic -Wall -Werror -Wno-error=format-overflow= -std=c99 -O2
AM_LDFLAGS =
ipaddrcheck_SOURCES = ipaddrcheck.c ipaddrcheck_functions.c