summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel@debian.org>2007-09-23 14:46:30 +0200
committerDaniel Baumann <daniel@debian.org>2007-09-23 14:46:30 +0200
commit9fda4b0552744a305a699855e2ad3907e8cab164 (patch)
treefe188681a51e406a3811bb708c6d3df31cb3e5a8 /debian/rules
parentbeec4f9fb766be23d575b070e398639d5a4a9c9d (diff)
downloadlive-boot-9fda4b0552744a305a699855e2ad3907e8cab164.tar.gz
live-boot-9fda4b0552744a305a699855e2ad3907e8cab164.zip
Adding casper 1.81+debian-1.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules12
1 files changed, 4 insertions, 8 deletions
diff --git a/debian/rules b/debian/rules
index 9441b3a..6fdc0f9 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,4 +1,4 @@
-#!/usr/bin/make -f
+#! /usr/bin/make -f
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
@@ -12,10 +12,10 @@ build-stamp:
# Setting BUILD_SYSTEM in the binary package
sed -i -e 's/\(BUILD_SYSTEM="\).*"/\1'$(BUILD_SYSTEM)'"/g' casper.conf
-ifeq ($(BUILD_SYSTEM),Debian)
- cp debian/control.debian debian/control
-else
+ifeq ($(BUILD_SYSTEM),Ubuntu)
cp debian/control.ubuntu debian/control
+else
+ cp debian/control.debian debian/control
endif
# Building package
@@ -83,11 +83,7 @@ binary-arch: build install
dh_testdir
dh_testroot
-ifeq ($(BUILD_SYSTEM),Debian)
- dh_installchangelogs -a debian/changelog.upstream
-else
dh_installchangelogs -a
-endif
dh_installdocs -a
dh_installman -a
dh_installexamples -a