summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorDaniel Baumann <daniel@debian.org>2012-04-05 08:05:20 +0200
committerDaniel Baumann <daniel@debian.org>2012-04-05 08:31:45 +0200
commit49bcda4f02e85fb1c648fd8fd00b8b989d2de752 (patch)
tree9e1ec9bd7724712396bafbd80cc52d627d6ffa18 /debian
parenta39a1678776b1bfe92e717f5abd5f55b6404b525 (diff)
downloadlive-boot-49bcda4f02e85fb1c648fd8fd00b8b989d2de752.tar.gz
live-boot-49bcda4f02e85fb1c648fd8fd00b8b989d2de752.zip
Moving initscript to live-config.
Keeping the initscript in live-boot is not really maintainable for different init systems. We would need to have, like live-config, several backend packages (live-boot-sysvinit, live-boot-systemd, live-boot-upstart) etc., plus, every combination with the different initrd system backend (initramfs-tools, dracut).
Diffstat (limited to 'debian')
-rw-r--r--debian/live-boot.init36
-rw-r--r--debian/live-boot.install1
-rw-r--r--debian/live-boot.lintian-overrides4
-rwxr-xr-xdebian/rules3
4 files changed, 0 insertions, 44 deletions
diff --git a/debian/live-boot.init b/debian/live-boot.init
deleted file mode 100644
index 373df1b..0000000
--- a/debian/live-boot.init
+++ /dev/null
@@ -1,36 +0,0 @@
-#!/bin/sh
-
-## live-boot contains the scripts that configure a Debian Live system during
-## the boot process (early userspace).
-##
-## This is the sysvinit script for live-boot.
-
-
-### BEGIN INIT INFO
-# Provides: live-boot
-# Required-Start: $syslog bootmisc
-# Required-Stop:
-# Should-Start: $local_fs
-# Should-Stop: halt reboot
-# Default-Start: S
-# Default-Stop: 0 6
-# Short-Description: Debian Live - System Configuration Scripts
-# Description: live-boot contains the scripts that configure a Debian
-# Live system during the boot process (early userspace).
-# X-Start-Before:
-# X-Stop-After: umountroot
-# X-Interactive: true
-### END INIT INFO
-
-case "${1}" in
- stop)
- if [ -e /lib/live/boot.sh ]
- then
- /lib/live/boot.sh
- fi
- ;;
-
- start|force-reload|restart)
-
- ;;
-esac
diff --git a/debian/live-boot.install b/debian/live-boot.install
index 85134eb..79474ce 100644
--- a/debian/live-boot.install
+++ b/debian/live-boot.install
@@ -1,3 +1,2 @@
-lib
sbin
usr/share/live-boot
diff --git a/debian/live-boot.lintian-overrides b/debian/live-boot.lintian-overrides
deleted file mode 100644
index aa345a5..0000000
--- a/debian/live-boot.lintian-overrides
+++ /dev/null
@@ -1,4 +0,0 @@
-# false positives, not applicable to live systems
-live-boot: init.d-script-missing-dependency-on-remote_fs /etc/init.d/live-boot: required-start
-live-boot: init.d-script-missing-dependency-on-remote_fs /etc/init.d/live-boot: required-stop
-live-boot: init.d-script-possible-missing-stop /etc/init.d/live-boot 1
diff --git a/debian/rules b/debian/rules
index 61a5e25..f480990 100755
--- a/debian/rules
+++ b/debian/rules
@@ -18,6 +18,3 @@ override_dh_builddeb:
override_dh_install:
dh_install --fail-missing
-
-override_dh_installinit:
- dh_installinit -p live-boot --no-restart-on-upgrade --no-start --update-rcd-params='start 89 0 6 .'