summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog6
-rw-r--r--debian/control4
-rwxr-xr-xdebian/rules39
3 files changed, 35 insertions, 14 deletions
diff --git a/debian/changelog b/debian/changelog
index a3b3592..52a4957 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+live-initramfs (1.87.6-1) unstable; urgency=medium
+
+ * New upstream release.
+
+ -- Daniel Baumann <daniel@debian.org> Mon, 4 Jun 2007 00:00:00 +0200
+
live-initramfs (1.87.5-1) unstable; urgency=medium
* New upstream release, replacing casper.
diff --git a/debian/control b/debian/control
index 5511d40..46c92b8 100644
--- a/debian/control
+++ b/debian/control
@@ -11,6 +11,7 @@ XS-VCS-Browse: http://svn.debian.org/wsvn/debian-live/dists/trunk/live-initramfs
Package: live-initramfs
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, eject, file, initramfs-tools, sudo, user-setup
+Recommends: live-sysvinit
Suggests: genext2fs, squashfs-tools
Conflicts: casper (<< 1.87)
Replaces: casper
@@ -24,6 +25,9 @@ Description: Debian Live initramfs hook
squashfs) is stored. If found, it will create a writable environment, using
unionfs, for Debian like systems to boot from.
.
+ You probably do not want to install this package onto a non-live system,
+ although it will do no harm.
+ .
Homepage: <http://debian-live.alioth.debian.org/>
.
live-initramfs is a fork of casper <http://packages.ubuntu.com/casper/>.
diff --git a/debian/rules b/debian/rules
index cde5630..0e8bbc7 100755
--- a/debian/rules
+++ b/debian/rules
@@ -50,22 +50,33 @@ install: build
mv debian/live-initramfs/usr/share/doc/live-initramfs/ChangeLog.casper debian/live-initramfs/usr/share/doc/live-initramfs/changelog.casper
binary-indep: build install
+ dh_testdir -i
+ dh_testroot -i
+ dh_installchangelogs -i docs/ChangeLog
+ dh_installdocs -i
+ dh_install -i
+ dh_compress -i
+ dh_fixperms -i
+ dh_installdeb -i
+ dh_gencontrol -i
+ dh_md5sums -i
+ dh_builddeb -i
binary-arch: build install
- dh_testdir
- dh_testroot
- dh_installchangelogs docs/ChangeLog
- dh_installdocs
- dh_install
- dh_installinit --no-restart-on-upgrade --no-start -- start 89 0 6 .
- dh_strip
- dh_compress
- dh_fixperms
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
+ dh_testdir -a
+ dh_testroot -a
+ dh_installchangelogs -a docs/ChangeLog
+ dh_installdocs -a
+ dh_install -a
+ dh_installinit -a --no-restart-on-upgrade --no-start -- start 89 0 6 .
+ dh_strip -a
+ dh_compress -a
+ dh_fixperms -a
+ dh_installdeb -a
+ dh_shlibdeps -a
+ dh_gencontrol -a
+ dh_md5sums -a
+ dh_builddeb -a
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install