summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Gollub <dgollub@att.com>2019-11-11 15:07:38 +0100
committerVyatta Package Maintainers <DL-vyatta-help@att.com>2019-11-13 17:08:02 +0000
commit822c8f60b72cca97fb2c86db37835a60917d1c7e (patch)
treed5593a4ed1cbb8e9709411679974355a41f0289e /debian/rules
downloadtacplusd-fc24abbcb1aedc71d4f74892689a8e9aa9958f98.tar.gz
tacplusd-fc24abbcb1aedc71d4f74892689a8e9aa9958f98.zip
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules17
1 files changed, 17 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..d029fd3
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,17 @@
+#!/usr/bin/make -f
+
+%:
+ dh $@ --with autoreconf,systemd
+
+# Don't start any daemon by default. This is up to configd.
+override_dh_systemd_enable:
+ dh_systemd_enable --name=tacplusd --no-enable
+
+override_dh_installinit:
+ dh_installinit --no-start
+
+override_dh_systemd_start:
+ dh_systemd_start --no-start
+
+override_dh_strip:
+ dh_strip --dbg-package=tacplusd-dbg