summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorAn-Cheng Huang <ancheng@vyatta.com>2007-11-14 16:24:17 -0800
committerAn-Cheng Huang <ancheng@vyatta.com>2007-11-14 16:24:17 -0800
commitbff0c156047ae6ca0bb9a5e04587ebe1d1ef5249 (patch)
tree6b8963bdf5c0057fd75cadfaa72605b73c972fad /debian
parent6804870eb94fccd56af93adc4687699091086660 (diff)
downloadvyatta-bash-bff0c156047ae6ca0bb9a5e04587ebe1d1ef5249.tar.gz
vyatta-bash-bff0c156047ae6ca0bb9a5e04587ebe1d1ef5249.zip
change packaging
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog6
-rw-r--r--debian/control45
-rw-r--r--debian/copyright2
-rwxr-xr-xdebian/rules334
4 files changed, 30 insertions, 357 deletions
diff --git a/debian/changelog b/debian/changelog
index 0dd230f..7b421f7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+vyatta-bash (0.1) unstable; urgency=low
+
+ * Initial release based on bash 3.1dfsg-8.
+
+ -- An-Cheng Huang <ancheng@vyatta.com> Mon, 12 Nov 2007 17:14:43 -0700
+
bash (3.1dfsg-8) unstable; urgency=high
* bash-doc: Install copyright file when building without the
diff --git a/debian/control b/debian/control
index b6d54a1..9d8af55 100644
--- a/debian/control
+++ b/debian/control
@@ -1,55 +1,24 @@
-Source: bash
+Source: vyatta-bash
Section: base
Priority: required
-Maintainer: Matthias Klose <doko@debian.org>
+Maintainer: An-Cheng Huang <ancheng@vyatta.com>
Standards-Version: 3.6.2
Build-Depends: autoconf, patch, bison, libncurses5-dev, texinfo, autotools-dev, debhelper (>= 4.1), texi2html, locales
Build-Depends-Indep: tetex-bin
-Package: bash
+Package: vyatta-bash
Architecture: any
Pre-Depends: ${shlibs:Pre-Depends}
-Depends: base-files (>= 2.1.12), debianutils (>= 2.15)
-Conflicts: bash-completion
-Replaces: bash-doc (<= 2.05-1), bash-completion
-Suggests: bash-doc
-Essential: yes
+Depends: base-files (>= 2.1.12), debianutils (>= 2.15), bash (>= 3.1)
Section: shells
Priority: required
-Description: The GNU Bourne Again SHell
+Description: The Vyatta Shell based on GNU bash
+ The Vyatta Shell based on GNU Bourne Again SHell.
+ .
Bash is an sh-compatible command language interpreter that executes
commands read from the standard input or from a file. Bash also
incorporates useful features from the Korn and C shells (ksh and csh).
.
Bash is ultimately intended to be a conformant implementation of the
IEEE POSIX Shell and Tools specification (IEEE Working Group 1003.2).
- .
- Included in the bash package is the Programmable Completion Code, by
- Ian Macdonald.
-
-Package: bash-minimal
-Architecture: any
-Depends: ${shlibs:Depends}, passwd (>= 1:4.0.3-10)
-Suggests: bash-doc
-Section: shells
-Priority: optional
-Description: The GNU Bourne Again SHell (minimal version)
- Bash is an sh-compatible command language interpreter that executes
- commands read from the standard input or from a file. Bash also
- incorporates useful features from the Korn and C shells (ksh and csh).
- .
- Configured using --enable-minimal-config.
-
-Package: bash-static
-Architecture: any
-Depends: passwd (>= 1:4.0.3-10)
-Suggests: bash-doc
-Section: shells
-Priority: optional
-Description: The GNU Bourne Again SHell (static version)
- Bash is an sh-compatible command language interpreter that executes
- commands read from the standard input or from a file. Bash also
- incorporates useful features from the Korn and C shells (ksh and csh).
- .
- Statically linked.
diff --git a/debian/copyright b/debian/copyright
index c0f7ea6..9a010ff 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -1,3 +1,5 @@
+The following is the original copyright of the Debian package.
+
This is Debian GNU/Linux's prepackaged version of the FSF's GNU Bash,
the Bourne Again SHell.
diff --git a/debian/rules b/debian/rules
index 60a9c6b..17de8e8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -36,13 +36,9 @@ with_installed_rl = no
debflags =
PWD := $(shell pwd)
-p = bash
-p_min = bash-minimal
-p_stat = bash-static
+p = vyatta-bash
d = debian/$(p)
-d_min = debian/$(p_min)
-d_stat = debian/$(p_stat)
conf_args = \
--with-curses \
@@ -55,24 +51,9 @@ ifeq ($(with_installed_rl),yes)
conf_args += --with-installed-readline
endif
-static_conf_args := $(conf_args) \
- --enable-static-link \
- --without-bash-malloc \
- --host=$(DEB_HOST_GNU_TYPE)
-
conf_args += --host=$(DEB_HOST_GNU_TYPE)
-min_conf_args = \
- --enable-minimal-config \
- --enable-largefile \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man
-min_conf_args += --host=$(DEB_HOST_GNU_TYPE)
-
-
-#build: bash-build minimal-build static-build preinst-build all-bashdb-build check
-build: before-build bash-build minimal-build static-build preinst-build
+build: before-build bash-build
before-build:
: # see #327477, needed to have HAVE_DEV_STDIN defined
@@ -99,76 +80,6 @@ bash-configure:
configure_args="$(conf_args)"
# ---------------------------------------------------------------------------
-# build minimal bash
-
-minimal-build:
- $(MAKE) -f debian/rules do-build-min \
- bash_src=bash \
- bash_patches="$(debian_patches)" \
- build=min \
- configure_args="$(min_conf_args)"
-minimal-configure:
- $(MAKE) -f debian/rules do-configure-min \
- bash_src=bash \
- bash_patches="$(debian_patches)" \
- build=min \
- configure_args="$(min_conf_args)"
-
-# ---------------------------------------------------------------------------
-# build static bash
-
-static-build:
- $(MAKE) -f debian/rules do-build-static \
- bash_src=bash \
- bash_patches="$(debian_patches)" \
- build=static \
- configure_args="$(static_conf_args)"
-static-configure:
- $(MAKE) -f debian/rules do-configure-static \
- bash_src=bash \
- bash_patches="$(debian_patches)" \
- build=static \
- configure_args="$(static_conf_args)"
-
-# ---------------------------------------------------------------------------
-# build standard bash
-
-all-bashdb-build: bashdb-build #bashdb-doc-build
-
-bashdb-build:
- DEBUGGER_START_FILE=/usr/share/bashdb/dbg-main.inc \
- $(MAKE) -f debian/rules do-build-bashdb \
- bash_src=bashdb \
- bash_patches="$(bashdb_patches)" \
- build=bashdb \
- configure_args="$(conf_args)"
-bashdb-configure:
- DEBUGGER_START_FILE=/usr/share/bashdb/dbg-main.inc \
- $(MAKE) -f debian/rules do-configure-bashdb \
- bash_src=bashdb \
- bash_patches="$(bashdb_patches)" \
- build=bashdb \
- configure_args="$(conf_args)"
-
-bashdb-doc-build: stamps/stamp-build-bashdb-doc
-stamps/stamp-build-bashdb-doc:
- cp -p build-bashdb/doc/version.texi bashdb/doc/
- cp -p build-bashdb/debugger/doc/version.texi bashdb/debugger/doc/
-# $(MAKE) -C build-bashdb doc
- $(MAKE) -C build-bashdb/debugger/doc
- touch stamps/stamp-build-bashdb-doc
-
-# ---------------------------------------------------------------------------
-
-bash-doc-build: stamps/stamp-build-bash-doc
-stamps/stamp-build-bash-doc:
-ifeq ($(with_gfdl),yes)
- rm -f bash/doc/bashref.info
- $(MAKE) -C build-bash/doc bashref.info bashref.pdf
-endif
- touch stamps/stamp-build-bash-doc
-
-# ---------------------------------------------------------------------------
check: stamps/stamp-check
stamps/stamp-check: bash-build
@@ -189,20 +100,14 @@ clean:
dh_testdir
dh_testroot
rm -rf stamps build-* bash bashdb
- rm -f debian/bash.preinst
rm -f debian/README.Debian
rm -rf locales
rm -f clear_console
dh_clean
-preinst-build: debian/bash.preinst
-debian/bash.preinst: debian/bash.preinst.c
- $(CC) -O2 -s -o debian/bash.preinst debian/bash.preinst.c
-
# ---------------------------------------------------------------------------
-
-install: bash-install #bashdb-install
+install: bash-install
bash-install: bash-build stamps/stamp-install-bash
stamps/stamp-install-bash: stamps/stamp-build-bash
@@ -210,15 +115,7 @@ stamps/stamp-install-bash: stamps/stamp-build-bash
dh_testroot
dh_clean -k -p$(p)
dh_installdirs -p$(p) \
- bin \
- etc/skel \
- etc/bash_completion.d \
- usr/share/doc/$(p)
-
-ifeq ($(with_gfdl),yes)
-# XXXXX
- cp -p build-bash/doc/*.info bash/doc/
-endif
+ bin
: # install it
$(MAKE) -C build-bash install \
@@ -226,58 +123,14 @@ endif
CFLAGS='$(CFLAGS)' \
YACC="$(YACC)" \
DESTDIR=$(PWD)/$(d)
- mv $(d)/usr/bin/bash $(d)/bin/.
- chmod 755 $(d)/usr/bin/bashbug
-ifneq ($(with_gfdl),yes)
- mkdir -p $(d)/usr/share/man/man1
- cp -p bash/doc/bash.1 $(d)/usr/share/man/man1/bash.1
-endif
-
- : # extra links
- ln -sf bash $(d)/bin/rbash
- ln -sf bash $(d)/bin/sh
- ln -sf bash.1 $(d)/usr/share/man/man1/sh.1
+ mv $(d)/usr/bin/vbash $(d)/bin/.
+ rmdir $(d)/usr/bin
- : # skeleton files
- $(ID) debian/etc.bash.bashrc $(d)/etc/bash.bashrc
- $(ID) debian/skel.bashrc $(d)/etc/skel/.bashrc
- $(ID) debian/skel.bash_profile $(d)/etc/skel/.bash_profile
- $(ID) debian/skel.bash_logout $(d)/etc/skel/.bash_logout
-
- : # clean_console
-ifneq (,$(findstring $(DEB_HOST_ARCH_OS), linux freebsd))
- $(IX) clear_console $(d)/usr/bin/
- $(ID) debian/clear_console.1 $(d)/usr/share/man/man1/
-endif
-
- : # install bash-completion
- $(ID) debian/bash_completion/bash_completion $(d)/etc/.
- cp -a debian/bash_completion/contrib \
- $(d)/usr/share/doc/$(p)/completion-contrib
- chmod 755 $(d)/usr/share/doc/$(p)/completion-contrib
- chmod 644 $(d)/usr/share/doc/$(p)/completion-contrib/*
- $(ID) debian/bash_completion/Changelog \
- $(d)/usr/share/doc/$(p)/changelog.bash_completion
- $(ID) debian/README.bash_completion $(d)/usr/share/doc/$(p)/
- cat debian/bash_completion/README \
- >> $(d)/usr/share/doc/$(p)/README.bash_completion
- $(ID) debian/bash_completion/BUGS \
- $(d)/usr/share/doc/bash/BUGS.bash_completion
-
-ifeq ($(with_gfdl),yes)
- : # files for the bash-doc package
- mv $(d)/usr/share/info/bash.info $(d)/usr/share/info/bashref.info
- ln -sf bashref.info $(d)/usr/share/info/bash.info
- : # mv $(d)/usr/share/info $(d_doc)/usr/share/
- rm -rf $(d)/usr/share/info
-endif
-
- : # cat debian/README stamps/stamp-patch-bash > debian/README.Debian
cat debian/README > debian/README.Debian
touch stamps/stamp-install-bash
-binary-bash: bash-install debian/bash.preinst
+binary-bash: bash-install
dh_testdir
dh_testroot
dh_installchangelogs -p$(p) bash/CWRU/changelog
@@ -285,63 +138,17 @@ binary-bash: bash-install debian/bash.preinst
bash/{CHANGES,NEWS,COMPAT,doc/INTRO,POSIX} \
debian/{README.Debian,README.abs-guide,README.commands} \
debian/inputrc.arrows
-ifeq ($(with_gfdl),yes)
- cp -p bash/doc/FAQ $(d)/usr/share/doc/$(p)/.
-endif
- cp -p debian/FAQ $(d)/usr/share/doc/$(p)/.
- dh_installman -p$(p) bash/doc/rbash.1 debian/bash-builtins.7
- dh_installmenu -p$(p)
dh_strip -p$(p)
dh_compress -p$(p)
dh_fixperms -p$(p)
- dh_shlibdeps -p$(p) -- -dPre-Depends $(d)/bin/bash debian/bash.preinst
+ dh_shlibdeps -p$(p) -- -dPre-Depends $(d)/bin/vbash
dh_installdeb -p$(p)
dh_gencontrol -p$(p)
dh_md5sums -p$(p)
dh_builddeb -p$(p)
-binary-static: static-build
- dh_testdir
- dh_testroot
- dh_clean -k -p$(p_stat)
- dh_installdirs -p$(p_stat) \
- bin \
- usr/share/man/man1
- cp -p build-static/bash $(d_stat)/bin/bash-static
- cp -p bash/doc/bash.1 $(d_stat)/usr/share/man/man1/bash-static.1
- dh_installdocs -p$(p_stat)
- dh_installchangelogs -p$(p_stat)
- dh_strip -p$(p_stat)
- dh_compress -p$(p_stat)
- dh_fixperms -p$(p_stat)
- dh_installdeb -p$(p_stat)
- dh_gencontrol -p$(p_stat)
- dh_md5sums -p$(p_stat)
- dh_builddeb -p$(p_stat)
-
-binary-minimal: minimal-build
- dh_testdir
- dh_testroot
- dh_clean -k -p$(p_min)
- dh_installdirs -p$(p_min) \
- bin \
- usr/share/man/man1
- cp -p build-min/bash $(d_min)/bin/bash-minimal
- cp -p debian/bash-minimal.1 $(d_min)/usr/share/man/man1/.
- dh_installdocs -p$(p_min)
- dh_installchangelogs -p$(p_min)
- dh_strip -p$(p_min)
- dh_compress -p$(p_min)
- dh_fixperms -p$(p_min)
- dh_shlibdeps -p$(p_min)
- dh_installdeb -p$(p_min)
- dh_gencontrol -p$(p_min)
- dh_md5sums -p$(p_min)
- dh_builddeb -p$(p_min)
-
-binary-indep: binary-doc
-binary-arch: binary-bash binary-builtins binary-static binary-minimal #binary-bashdb
-binary: binary-indep binary-arch
+binary-arch: binary-bash
+binary: binary-arch
# ---------------------------------------------------------------------------
# common rules for all bash build variations
@@ -355,11 +162,6 @@ stamps/stamp-build-$(build): stamps/stamp-configure-$(build)
YACC="$(YACC)" \
deb_builddir=build-$(build)/ \
$(debflags)
-ifeq ($(with_gfdl),yes)
-# XXX not done by toplevel make?
- $(MAKE) -C build-$(build)/doc \
- bash.info
-endif
touch stamps/stamp-build-$(build)
do-configure-$(build): stamps/stamp-configure-$(build)
@@ -376,116 +178,15 @@ stamps/stamp-configure-$(build): stamps/stamp-unpack-$(bash_src)
fi
touch stamps/stamp-configure-$(build)
-patchdir = debian/patches
-debian_patches = \
- bash31-001 \
- bash31-002 \
- bash31-003 \
- bash31-004 \
- bash31-005 \
- bash31-006 \
- bash31-007 \
- bash31-008 \
- bash31-009 \
- bash31-010 \
- bash31-011 \
- bash31-012 \
- bash31-013 \
- bash31-014 \
- bash31-015 \
- bash31-016 \
- bash31-017 \
- readline51-001 \
- rl-inputrc \
- bashbug-editor \
- deb-bash-config \
- deb-examples \
- man-arithmetic \
- man-fignore \
- man-bashrc \
- man-bashlogout \
- man-substring-exp \
- man-nocaseglob \
- man-test \
- man-test2 \
- man-net-redirections \
- privmode \
- rbash-manpage \
- command-not-found \
- bash-default-editor \
- ulimit \
- po-sv \
- bash-subst-param-length \
- pgrp-pipe \
- input-err \
- read-memleak \
- login-shell \
- man-typos \
-
-ifeq ($(with_gfdl),yes)
- debian_patches += \
- bash31-002-doc \
- command-not-found-doc \
- man-substring-exp-doc \
- man-test2-doc \
- ulimit-doc \
- man-net-redirections-doc \
-
-endif
-
-# all debian_patches, without bash205b-*
-# patches integrated in bashdb: builtins-shift, execute-cmd, man-arithmetic,
-# man-builtin, man-fignore, random, rbash-manpage, report-155436,
-# rl-8bit-init, s390-build
-# and bashdb patch
-# rbash-manpage \
-
-bashdb_patches = \
- bashdb \
- rl-examples-bdb \
- rl-inputrc \
- bashbug-editor \
- deb-bash-config \
- deb-examples \
- privmode \
-
-# various \
-
-# these are applied in bashdb cvs as well
-# man-arithmetic \
-# man-fignore \
-# random \
-# report-155436 \
-# s390-build \
-# builtins-shift
-
-#patch-$(bash_src): stamps/stamp-patch-$(bash_src)
-#stamps/stamp-patch-$(bash_src): stamps/stamp-unpack-$(bash_src) \
-# $(foreach p,$(bash_patches),stamps/stamp-patch-$(bash_src)-$(p))
-# echo -e "\nPatches applied in this version:" > pxxx
-# for i in $(bash_patches); do \
-# echo -e "\n$$i:" >> pxxx; \
-# sed -n 's/^# *DP: */ /p' $(patchdir)/$$i.dpatch >> pxxx; \
-# done
-# mv -f pxxx $@
-
-#stamps/stamp-patch-$(bash_src)-%: $(patchdir)/%.dpatch
-# if [ -x $< ]; then true; else chmod +x $<; fi
-# if [ -f $@ ]; then \
-# echo "$* patches already applied."; exit 1; \
-# fi
-# $< -patch -d $(bash_src)
-# echo "$* patches applied." > $@
-
unpack-$(bash_src): stamps/stamp-unpack-$(bash_src)
stamps/stamp-unpack-$(bash_src):
mkdir -p stamps
rm -rf bash-$(VERSION) $(bash_src)
rm -f stamps/stamp-patch-$(bash_src){,-*}
tar c --exclude='bash-src.tar' --exclude='debian' --exclude='.git' \
- --exclude='stamps' --exclude='bash' --exclude='build-bash' \
- --exclude='build-min' --exclude='build-static' \
- -f bash-src.tar .
+ --exclude='stamps' --exclude='bash' --exclude='build-bash' \
+ --exclude='build-min' --exclude='build-static' \
+ -f bash-src.tar .
mkdir -p $(bash_src)
tar x -C $(bash_src) -f bash-src.tar
rm -f bash-src.tar
@@ -493,13 +194,8 @@ stamps/stamp-unpack-$(bash_src):
cp -p /usr/share/misc/config.* $(bash_src)/support/.
touch stamps/stamp-unpack-$(bash_src)
-.PHONY: unpack patch binary binary-arch binary-indep clean \
- build bash-build minimal-build static-build preinst-build \
- all-bashdb-build bashdb-build bashdb-doc-build \
- check \
- bash-configure minimal-configure static-configure bashdb-configure \
- binary-doc binary-bash binary-builtins binary-static binary-bashdb \
- install bash-install bashdb-install
+.PHONY: unpack patch binary binary-arch clean build bash-build \
+ check bash-configure binary-bash install bash-install
# Local Variables:
# mode: makefile