summaryrefslogtreecommitdiff
path: root/lib/tilde
diff options
context:
space:
mode:
Diffstat (limited to 'lib/tilde')
-rw-r--r--lib/tilde/Makefile.in23
-rw-r--r--lib/tilde/shell.c21
-rw-r--r--lib/tilde/tilde.c34
-rw-r--r--lib/tilde/tilde.h29
4 files changed, 52 insertions, 55 deletions
diff --git a/lib/tilde/Makefile.in b/lib/tilde/Makefile.in
index a9d3741..d5506c5 100644
--- a/lib/tilde/Makefile.in
+++ b/lib/tilde/Makefile.in
@@ -4,21 +4,20 @@
# #
####################################################################
-# Copyright (C) 1996-2005 Free Software Foundation, Inc.
+# Copyright (C) 1996-2009 Free Software Foundation, Inc.
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2, or (at your option)
-# any later version.
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111 USA.
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
srcdir = @srcdir@
VPATH = .:@srcdir@
diff --git a/lib/tilde/shell.c b/lib/tilde/shell.c
index a45af2d..40a95b6 100644
--- a/lib/tilde/shell.c
+++ b/lib/tilde/shell.c
@@ -1,24 +1,23 @@
/* shell.c -- tilde utility functions that are normally provided by
bash when readline is linked as part of the shell. */
-/* Copyright (C) 1998 Free Software Foundation, Inc.
+/* Copyright (C) 1998-2009 Free Software Foundation, Inc.
This file is part of the GNU Tilde Library.
- The GNU Tilde Library is free software; you can redistribute it
- and/or modify it under the terms of the GNU General Public License
- as published by the Free Software Foundation; either version 2, or
+ The GNU Tilde Library is free software: you can redistribute it and/or
+ modify it under the terms of the GNU General Public License as published
+ by the Free Software Foundation, either version 3 of the License, or
(at your option) any later version.
- The GNU Tilde Library is distributed in the hope that it will be
- useful, but WITHOUT ANY WARRANTY; without even the implied warranty
- of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ The GNU Tilde Library is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU General Public License for more details.
- The GNU General Public License is often shipped with GNU software, and
- is generally kept in a file called COPYING or LICENSE. If you do not
- have a copy of the license, write to the Free Software Foundation,
- 59 Temple Place, Suite 330, Boston, MA 02111 USA. */
+ You should have received a copy of the GNU General Public License
+ along with the GNU Tilde Library. If not, see <http://www.gnu.org/licenses/>.
+*/
#if defined (HAVE_CONFIG_H)
# include <config.h>
diff --git a/lib/tilde/tilde.c b/lib/tilde/tilde.c
index 1b76c9f..088ff15 100644
--- a/lib/tilde/tilde.c
+++ b/lib/tilde/tilde.c
@@ -1,23 +1,23 @@
/* tilde.c -- Tilde expansion code (~/foo := $HOME/foo). */
-/* Copyright (C) 1988,1989 Free Software Foundation, Inc.
+/* Copyright (C) 1988-2009 Free Software Foundation, Inc.
- This file is part of GNU Readline, a library for reading lines
- of text with interactive input and history editing.
+ This file is part of the GNU Readline Library (Readline), a library
+ for reading lines of text with interactive input and history editing.
- Readline is free software; you can redistribute it and/or modify it
- under the terms of the GNU General Public License as published by the
- Free Software Foundation; either version 2, or (at your option) any
- later version.
+ Readline is free software: you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation, either version 3 of the License, or
+ (at your option) any later version.
- Readline is distributed in the hope that it will be useful, but
- WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
- General Public License for more details.
+ Readline is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
You should have received a copy of the GNU General Public License
- along with Readline; see the file COPYING. If not, write to the Free
- Software Foundation, 59 Temple Place, Suite 330, Boston, MA 02111 USA. */
+ along with Readline. If not, see <http://www.gnu.org/licenses/>.
+*/
#if defined (HAVE_CONFIG_H)
# include <config.h>
@@ -236,7 +236,7 @@ tilde_expand (string)
string += end;
expansion = tilde_expand_word (tilde_word);
- free (tilde_word);
+ xfree (tilde_word);
len = strlen (expansion);
#ifdef __CYGWIN__
@@ -251,7 +251,7 @@ tilde_expand (string)
strcpy (result + result_index, expansion);
result_index += len;
}
- free (expansion);
+ xfree (expansion);
}
result[result_index] = '\0';
@@ -377,7 +377,7 @@ tilde_expand_word (filename)
if (expansion)
{
dirname = glue_prefix_and_suffix (expansion, filename, user_len);
- free (username);
+ xfree (username);
free (expansion);
return (dirname);
}
@@ -414,7 +414,7 @@ tilde_expand_word (filename)
dirname = glue_prefix_and_suffix (user_entry->pw_dir, filename, user_len);
#endif
- free (username);
+ xfree (username);
#if defined (HAVE_GETPWENT)
endpwent ();
#endif
diff --git a/lib/tilde/tilde.h b/lib/tilde/tilde.h
index c58ce20..e26dd04 100644
--- a/lib/tilde/tilde.h
+++ b/lib/tilde/tilde.h
@@ -1,25 +1,24 @@
/* tilde.h: Externally available variables and function in libtilde.a. */
-/* Copyright (C) 1992 Free Software Foundation, Inc.
+/* Copyright (C) 1992-2009 Free Software Foundation, Inc.
- This file contains the Readline Library (the Library), a set of
+ This file contains the Readline Library (Readline), a set of
routines for providing Emacs style line input to programs that ask
for it.
- The Library is free software; you can redistribute it and/or modify
+ Readline is free software: you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
- the Free Software Foundation; either version 2, or (at your option)
- any later version.
-
- The Library is distributed in the hope that it will be useful, but
- WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
- General Public License for more details.
-
- The GNU General Public License is often shipped with GNU software, and
- is generally kept in a file called COPYING or LICENSE. If you do not
- have a copy of the license, write to the Free Software Foundation,
- 59 Temple Place, Suite 330, Boston, MA 02111 USA. */
+ the Free Software Foundation, either version 3 of the License, or
+ (at your option) any later version.
+
+ Readline is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with Readline. If not, see <http://www.gnu.org/licenses/>.
+*/
#if !defined (_TILDE_H_)
# define _TILDE_H_