summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/control6
-rwxr-xr-xdebian/rules7
2 files changed, 9 insertions, 4 deletions
diff --git a/debian/control b/debian/control
index 1737d8c..d36af62 100644
--- a/debian/control
+++ b/debian/control
@@ -15,4 +15,8 @@ Pre-Depends:
Suggests:
Replaces:
Description: Vyatta version of the biosdevname utility.
-
+ Provides biosdevname which takes a kernel device name as an
+ argument, and returns the BIOS-given name it "should" be. This is
+ necessary on systems where the BIOS name for a given device (e.g. the
+ label on the chassis is "Gb1") doesn't map directly and obviously to
+ the kernel name (e.g. eth0).
diff --git a/debian/rules b/debian/rules
index 4fdabca..68f197c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -22,9 +22,7 @@ CFLAGS = -Wall -g
configure = ./configure
configure += --host=$(DEB_HOST_GNU_TYPE)
configure += --build=$(DEB_BUILD_GNU_TYPE)
-# configure += --prefix=/opt/vyatta
-# configure += --mandir=\$${prefix}/share/man
-# configure += --infodir=\$${prefix}/share/info
+configure += --mandir=/usr/share/man
configure += CFLAGS="$(CFLAGS)"
configure += LDFLAGS="-Wl,-z,defs"
@@ -74,6 +72,9 @@ install: build
install -D --mode=0644 debian/lintian $(PKGDIR)/usr/share/lintian/overrides/$(PACKAGE)
install -D --mode=0644 debian/linda $(PKGDIR)/usr/share/linda/overrides/$(PACKAGE)
+ # We don't need statically linked version of biosdevname
+ rm -f $(PKGDIR)/sbin/biosdevnameS
+
# We don't use the rules file from this package
rm -rf $(PKGDIR)/etc/udev/rules.d