summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Hemminger <stephen.hemminger@vyatta.com>2010-01-04 15:20:41 -0800
committerStephen Hemminger <stephen.hemminger@vyatta.com>2010-01-04 15:20:41 -0800
commitaa6b1b44036e5b3058c6a2bb8469ea6f7b2f0738 (patch)
treed4a9724bde05e049fc9db5c3a908681ffcda287e
parent830eee9598fef9e2b6986882628467b46767601b (diff)
parent7ffc9cd756a4c6a8b9b7ea1d9ba453e23998f5b6 (diff)
downloadvyatta-cfg-firewall-aa6b1b44036e5b3058c6a2bb8469ea6f7b2f0738.tar.gz
vyatta-cfg-firewall-aa6b1b44036e5b3058c6a2bb8469ea6f7b2f0738.zip
Merge branch 'kenwood' of suva.vyatta.com:/git/vyatta-cfg-firewall into kenwood
-rw-r--r--debian/changelog7
-rw-r--r--lib/Vyatta/IpTables/Rule.pm1
2 files changed, 8 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 2235470..3febfa1 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+vyatta-cfg-firewall (0.13.7-68) unstable; urgency=low
+
+ * Fix Bug 5173 Firewall becomes out of sync with iptables when logging
+ is used
+
+ -- Mohit Mehta <mohit.mehta@vyatta.com> Tue, 22 Dec 2009 21:01:08 -0800
+
vyatta-cfg-firewall (0.13.7-67) unstable; urgency=low
* added required keyword to help text.
diff --git a/lib/Vyatta/IpTables/Rule.pm b/lib/Vyatta/IpTables/Rule.pm
index 5fec1b3..6105ae7 100644
--- a/lib/Vyatta/IpTables/Rule.pm
+++ b/lib/Vyatta/IpTables/Rule.pm
@@ -309,6 +309,7 @@ sub get_num_ipt_rules {
if (("$self->{_log}" eq "enable") && (("$self->{_action}" eq "drop")
|| ("$self->{_action}" eq "accept")
|| ("$self->{_action}" eq "reject")
+ || ("$self->{_action}" eq "inspect")
|| ("$self->{_action}" eq "modify"))) {
$ipt_rules += 1;
$ipt_rules++ if $protocol_tcpudp == 1;