summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBob Gilligan <gilligan@sydney.vyatta.com>2007-12-10 17:40:27 -0800
committerBob Gilligan <gilligan@sydney.vyatta.com>2007-12-10 17:40:27 -0800
commita6d5039dd4936734b0a28d04a1e497280a342491 (patch)
tree880fc1a49a87850129c1b8be50f97646cf79cd86 /Makefile.am
downloadvyatta-cfg-firewall-a6d5039dd4936734b0a28d04a1e497280a342491.tar.gz
vyatta-cfg-firewall-a6d5039dd4936734b0a28d04a1e497280a342491.zip
Initial setup of vyatta-cfg-firewall package.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..a155f70
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,22 @@
+cfgdir = $(datadir)/vyatta-cfg/templates
+share_perl5dir = /opt/vyatta/share/perl5
+
+bin_SCRIPTS =
+sbin_SCRIPTS =
+sysconf_DATA =
+share_perl5_DATA =
+
+sbin_SCRIPTS += scripts/firewall/vyatta-firewall.pl
+sbin_SCRIPTS += scripts/firewall/vyatta-show-firewall.pl
+
+share_perl5_DATA += scripts/firewall/VyattaIpTablesAddressFilter.pm
+share_perl5_DATA += scripts/firewall/VyattaIpTablesRule.pm
+
+
+cpiop = find . ! -regex '\(.*~\|.*\.bak\|.*\.swp\|.*\#.*\#\)' -print0 | \
+ cpio -0pd
+
+install-exec-hook:
+ mkdir -p $(DESTDIR)$(cfgdir)
+ cd templates; $(cpiop) $(DESTDIR)$(cfgdir)
+