summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBob Gilligan <gilligan@vyatta.com>2009-02-24 16:34:00 -0800
committerBob Gilligan <gilligan@vyatta.com>2009-02-24 16:34:00 -0800
commited474cdf0e084d653ed06916f0ec297810e23831 (patch)
treebd5f45c46078a048842d5a08cf87bf1bc7679064 /Makefile.am
parentd8520ae0d6930a29a3e46d4d385b021fc3733024 (diff)
downloadvyatta-cfg-firewall-ed474cdf0e084d653ed06916f0ec297810e23831.tar.gz
vyatta-cfg-firewall-ed474cdf0e084d653ed06916f0ec297810e23831.zip
Allow IPv6 firewall rulesets to be configured on an interface independent of IPv4.
Replaced the hand-coded config templates under each type of interface with script-generated templates. This should be easier to maintain as we add new types of interfaces. Added sub-trees for "modify", "ipv6-name" and "ipv6-modify" under "in", "out" and "local" for all interfaces. Added command-completion for ruleset names being configured on an interface.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index c771b11..a140082 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -15,9 +15,17 @@ share_perl5_DATA += lib/Vyatta/IpTables/AddressFilter.pm
share_perl5_DATA += lib/Vyatta/IpTables/IpSet.pm
cpiop = find . ! -regex '\(.*~\|.*\.bak\|.*\.swp\|.*\#.*\#\)' -print0 | \
- cpio -0pd
+ cpio -0pdu
+
+
+all-local:
+ ./gen-interface-templates.pl
+
+clean-local:
+ rm -rf generated-templates
install-exec-hook:
mkdir -p $(DESTDIR)$(cfgdir)
- cd templates; $(cpiop) $(DESTDIR)$(cfgdir)
+ cd templates; $(cpiop) $(DESTDIR)$(cfgdir); cd ..
+ cd generated-templates; $(cpiop) $(DESTDIR)$(cfgdir); cd ..