summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBob Gilligan <gilligan@sydney.vyatta.com>2007-12-10 17:40:27 -0800
committerBob Gilligan <gilligan@sydney.vyatta.com>2007-12-10 17:40:27 -0800
commita6d5039dd4936734b0a28d04a1e497280a342491 (patch)
tree880fc1a49a87850129c1b8be50f97646cf79cd86 /configure.ac
downloadvyatta-cfg-firewall-a6d5039dd4936734b0a28d04a1e497280a342491.tar.gz
vyatta-cfg-firewall-a6d5039dd4936734b0a28d04a1e497280a342491.zip
Initial setup of vyatta-cfg-firewall package.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 30 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..cf40e61
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,30 @@
+# Process this file with autoconf to produce a configure script.
+AC_PREREQ(2.59)
+
+m4_define([VERSION_ID], [m4_esyscmd([
+ if test -f .version ; then
+ head -n 1 .version | tr -d \\n
+ else
+ echo -n 2.4
+ fi])])
+AC_INIT([vyatta-cfg-firewall], VERSION_ID, [vyatta-support@vyatta.com])
+
+test -n "$VYATTA_VERSION" || VYATTA_VERSION=$PACKAGE_VERSION
+
+AC_CONFIG_AUX_DIR([config])
+AM_INIT_AUTOMAKE([gnu no-dist-gzip dist-bzip2 subdir-objects])
+AC_PREFIX_DEFAULT([/opt/vyatta])
+
+AC_ARG_ENABLE([nostrip],
+ AC_HELP_STRING([--enable-nostrip],
+ [include -nostrip option during packaging]),
+ [NOSTRIP=-nostrip], [NOSTRIP=])
+
+AC_CONFIG_FILES(
+ [Makefile]
+ [debian/vyatta-cfg-firewall.postinst])
+
+AC_SUBST(NOSTRIP)
+
+AC_OUTPUT
+