summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Hemminger <stephen.hemminger@vyatta.com>2009-06-01 16:07:15 -0700
committerStephen Hemminger <stephen.hemminger@vyatta.com>2009-06-01 16:07:15 -0700
commitd14face4635efff9ce7897bb7cdb23d640a5d5da (patch)
treec853a0b7552114017367c7ee5502091ef9e1e112
parent59bd1079cd35353631fc505aec6d0537e21203cf (diff)
parent8a9faf63f172a37fc12f43e504f94ce92d863a1a (diff)
downloadvyatta-cfg-qos-d14face4635efff9ce7897bb7cdb23d640a5d5da.tar.gz
vyatta-cfg-qos-d14face4635efff9ce7897bb7cdb23d640a5d5da.zip
Merge branch 'jenner' into kenwood
Conflicts: debian/changelog
-rw-r--r--debian/changelog6
-rw-r--r--lib/Vyatta/Qos/Util.pm5
-rwxr-xr-xscripts/vyatta-qos-util.pl2
-rw-r--r--templates/qos-policy/network-emulator/node.tag/bandwidth/node.def2
-rw-r--r--templates/qos-policy/network-emulator/node.tag/burst/node.def2
-rw-r--r--templates/qos-policy/network-emulator/node.tag/network-delay/node.def2
-rw-r--r--templates/qos-policy/network-emulator/node.tag/packet-corruption/node.def2
-rw-r--r--templates/qos-policy/network-emulator/node.tag/packet-loss/node.def2
-rw-r--r--templates/qos-policy/network-emulator/node.tag/packet-reordering/node.def2
-rw-r--r--templates/qos-policy/random-detect/node.tag/bandwidth/node.def4
-rw-r--r--templates/qos-policy/rate-limit/node.tag/bandwidth/node.def2
-rw-r--r--templates/qos-policy/rate-limit/node.tag/burst/node.def2
-rw-r--r--templates/qos-policy/rate-limit/node.tag/latency/node.def2
-rw-r--r--templates/qos-policy/round-robin/node.tag/class/node.tag/match/node.tag/ip/dscp/node.def2
-rw-r--r--templates/qos-policy/round-robin/node.tag/class/node.tag/match/node.tag/ip/protocol/node.def2
-rw-r--r--templates/qos-policy/round-robin/node.tag/class/node.tag/match/node.tag/ipv6/dscp/node.def2
-rw-r--r--templates/qos-policy/round-robin/node.tag/class/node.tag/match/node.tag/ipv6/protocol/node.def2
-rw-r--r--templates/qos-policy/traffic-limiter/node.tag/class/node.tag/bandwidth/node.def2
-rw-r--r--templates/qos-policy/traffic-limiter/node.tag/class/node.tag/burst/node.def2
-rw-r--r--templates/qos-policy/traffic-limiter/node.tag/class/node.tag/match/node.tag/ip/dscp/node.def2
-rw-r--r--templates/qos-policy/traffic-limiter/node.tag/class/node.tag/match/node.tag/ip/protocol/node.def2
-rw-r--r--templates/qos-policy/traffic-limiter/node.tag/class/node.tag/match/node.tag/ipv6/dscp/node.def2
-rw-r--r--templates/qos-policy/traffic-limiter/node.tag/class/node.tag/match/node.tag/ipv6/protocol/node.def2
-rw-r--r--templates/qos-policy/traffic-shaper/node.tag/bandwidth/node.def4
-rw-r--r--templates/qos-policy/traffic-shaper/node.tag/class/node.tag/bandwidth/node.def2
-rw-r--r--templates/qos-policy/traffic-shaper/node.tag/class/node.tag/burst/node.def2
-rw-r--r--templates/qos-policy/traffic-shaper/node.tag/class/node.tag/ceiling/node.def2
-rw-r--r--templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/ip/dscp/node.def2
-rw-r--r--templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/ip/protocol/node.def2
-rw-r--r--templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/ipv6/dscp/node.def2
-rw-r--r--templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/ipv6/protocol/node.def2
-rw-r--r--templates/qos-policy/traffic-shaper/node.tag/class/node.tag/set-dscp/node.def2
-rw-r--r--templates/qos-policy/traffic-shaper/node.tag/default/bandwidth/node.def2
-rw-r--r--templates/qos-policy/traffic-shaper/node.tag/default/burst/node.def2
-rw-r--r--templates/qos-policy/traffic-shaper/node.tag/default/ceiling/node.def2
-rw-r--r--templates/qos-policy/traffic-shaper/node.tag/default/set-dscp/node.def2
36 files changed, 41 insertions, 42 deletions
diff --git a/debian/changelog b/debian/changelog
index ba80e2c..7f336b0 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,9 +1,3 @@
-vyatta-cfg-qos (0.13.7) unstable; urgency=low
-
- * UNRELEASED
-
- -- An-Cheng Huang <ancheng@vyatta.com> Fri, 29 May 2009 18:35:17 -0700
-
vyatta-cfg-qos (0.13.6) unstable; urgency=low
* Mark probability must be > 0
diff --git a/lib/Vyatta/Qos/Util.pm b/lib/Vyatta/Qos/Util.pm
index 151b1d3..242e2b4 100644
--- a/lib/Vyatta/Qos/Util.pm
+++ b/lib/Vyatta/Qos/Util.pm
@@ -27,6 +27,9 @@ use base qw(Exporter);
sub get_num {
use POSIX qw(strtod);
my ($str) = @_;
+ return unless $str;
+
+ # remove leading/trailing spaces
$str =~ s/^\s+//;
$str =~ s/\s+$//;
@@ -86,6 +89,8 @@ sub getAutoRate {
sub getRate {
my $rate = shift;
+ $rate or die "Rate not defined";
+
my ( $num, $suffix ) = get_num($rate);
defined $num
diff --git a/scripts/vyatta-qos-util.pl b/scripts/vyatta-qos-util.pl
index 9468065..6dae105 100755
--- a/scripts/vyatta-qos-util.pl
+++ b/scripts/vyatta-qos-util.pl
@@ -57,7 +57,7 @@ GetOptions(
) or usage();
getPercent($percent) if $percent;
-getPercentOrRate($percent) if $percentrate;
+getPercentOrRate($percentrate) if $percentrate;
getRate($rate) if $rate;
getBurstSize($burst) if $burst;
getProtocol($protocol) if $protocol;
diff --git a/templates/qos-policy/network-emulator/node.tag/bandwidth/node.def b/templates/qos-policy/network-emulator/node.tag/bandwidth/node.def
index 3e48fd3..db8ca65 100644
--- a/templates/qos-policy/network-emulator/node.tag/bandwidth/node.def
+++ b/templates/qos-policy/network-emulator/node.tag/bandwidth/node.def
@@ -1,6 +1,6 @@
type: txt
help: Set the bandwidth limit
-syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --rate \"$VAR(@)\""
+syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --rate $VAR(@)"
comp_help: Allowed values:
<number> Bandwidth in Kbps per second
<number><suffix> Value with scaling suffix
diff --git a/templates/qos-policy/network-emulator/node.tag/burst/node.def b/templates/qos-policy/network-emulator/node.tag/burst/node.def
index 56174bb..4df45de 100644
--- a/templates/qos-policy/network-emulator/node.tag/burst/node.def
+++ b/templates/qos-policy/network-emulator/node.tag/burst/node.def
@@ -1,7 +1,7 @@
type: txt
help: Set the burst size
default: "15k"
-syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --burst \"$VAR(@)\""
+syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --burst $VAR(@)"
comp_help: Allowed values:
<number> Burst size in bytes
<number><suffix> Size with scaling suffix (kb, mb, gb)
diff --git a/templates/qos-policy/network-emulator/node.tag/network-delay/node.def b/templates/qos-policy/network-emulator/node.tag/network-delay/node.def
index ac08e1c..40b8437 100644
--- a/templates/qos-policy/network-emulator/node.tag/network-delay/node.def
+++ b/templates/qos-policy/network-emulator/node.tag/network-delay/node.def
@@ -1,5 +1,5 @@
type: txt
-syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --time \"$VAR(@)\""
+syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --time $VAR(@)"
help: Setup network delay
comp_help: Additional network delay in milliseconds
<number> Latency in milliseconds
diff --git a/templates/qos-policy/network-emulator/node.tag/packet-corruption/node.def b/templates/qos-policy/network-emulator/node.tag/packet-corruption/node.def
index 9533609..fb0e975 100644
--- a/templates/qos-policy/network-emulator/node.tag/packet-corruption/node.def
+++ b/templates/qos-policy/network-emulator/node.tag/packet-corruption/node.def
@@ -1,6 +1,6 @@
type: txt
help: Set emulated packet data corruption rate
-syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --percent \"$VAR(@)\""
+syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --percent $VAR(@)"
comp_help: Allowed values:
<number>%% Percentage of packets affected
diff --git a/templates/qos-policy/network-emulator/node.tag/packet-loss/node.def b/templates/qos-policy/network-emulator/node.tag/packet-loss/node.def
index 16bc099..6501d7a 100644
--- a/templates/qos-policy/network-emulator/node.tag/packet-loss/node.def
+++ b/templates/qos-policy/network-emulator/node.tag/packet-loss/node.def
@@ -1,6 +1,6 @@
type: txt
help: Set emulated packet loss rate
-syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --percent \"$VAR(@)\""
+syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --percent $VAR(@)"
comp_help: Allowed values:
<number>%% Percentage of packets affected
diff --git a/templates/qos-policy/network-emulator/node.tag/packet-reordering/node.def b/templates/qos-policy/network-emulator/node.tag/packet-reordering/node.def
index 278d4a5..ee5c64a 100644
--- a/templates/qos-policy/network-emulator/node.tag/packet-reordering/node.def
+++ b/templates/qos-policy/network-emulator/node.tag/packet-reordering/node.def
@@ -1,6 +1,6 @@
type: txt
help: Set emulated packet reordering percentage
-syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --percent \"$VAR(@)\""
+syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --percent $VAR(@)"
commit:expression: $VAR(../network-delay) != "" ; \
"Must specify network-delay for packet reordering"
comp_help: Allowed values:
diff --git a/templates/qos-policy/random-detect/node.tag/bandwidth/node.def b/templates/qos-policy/random-detect/node.tag/bandwidth/node.def
index 76fa6e2..eb0d4d9 100644
--- a/templates/qos-policy/random-detect/node.tag/bandwidth/node.def
+++ b/templates/qos-policy/random-detect/node.tag/bandwidth/node.def
@@ -1,8 +1,8 @@
type: txt
help: Set the available bandwidth for this policy
default: "auto"
-syntax:expression: exec "[[ \"$VAR(@)\" == \"auto\" ]] || \
- /opt/vyatta/sbin/vyatta-qos-util.pl --rate \"$VAR(@)\""
+syntax:expression: $VAR(@) == "auto" || \
+ exec "/opt/vyatta/sbin/vyatta-qos-util.pl --rate $VAR(@)"
comp_help: Allowed values:
auto Set bandwidth based on interface speed (default)
<number> Bandwidth in Kbps
diff --git a/templates/qos-policy/rate-limit/node.tag/bandwidth/node.def b/templates/qos-policy/rate-limit/node.tag/bandwidth/node.def
index 3e48fd3..db8ca65 100644
--- a/templates/qos-policy/rate-limit/node.tag/bandwidth/node.def
+++ b/templates/qos-policy/rate-limit/node.tag/bandwidth/node.def
@@ -1,6 +1,6 @@
type: txt
help: Set the bandwidth limit
-syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --rate \"$VAR(@)\""
+syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --rate $VAR(@)"
comp_help: Allowed values:
<number> Bandwidth in Kbps per second
<number><suffix> Value with scaling suffix
diff --git a/templates/qos-policy/rate-limit/node.tag/burst/node.def b/templates/qos-policy/rate-limit/node.tag/burst/node.def
index 56174bb..4df45de 100644
--- a/templates/qos-policy/rate-limit/node.tag/burst/node.def
+++ b/templates/qos-policy/rate-limit/node.tag/burst/node.def
@@ -1,7 +1,7 @@
type: txt
help: Set the burst size
default: "15k"
-syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --burst \"$VAR(@)\""
+syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --burst $VAR(@)"
comp_help: Allowed values:
<number> Burst size in bytes
<number><suffix> Size with scaling suffix (kb, mb, gb)
diff --git a/templates/qos-policy/rate-limit/node.tag/latency/node.def b/templates/qos-policy/rate-limit/node.tag/latency/node.def
index 486bfa3..bef5491 100644
--- a/templates/qos-policy/rate-limit/node.tag/latency/node.def
+++ b/templates/qos-policy/rate-limit/node.tag/latency/node.def
@@ -1,5 +1,5 @@
type: txt
-syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --time \"$VAR(@)\""
+syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --time $VAR(@)"
default: "50ms"
help: Set maximum latency
comp_help: Limit on the queue size based on latency
diff --git a/templates/qos-policy/round-robin/node.tag/class/node.tag/match/node.tag/ip/dscp/node.def b/templates/qos-policy/round-robin/node.tag/class/node.tag/match/node.tag/ip/dscp/node.def
index 4f3f18e..d02dc5c 100644
--- a/templates/qos-policy/round-robin/node.tag/class/node.tag/match/node.tag/ip/dscp/node.def
+++ b/templates/qos-policy/round-robin/node.tag/class/node.tag/match/node.tag/ip/dscp/node.def
@@ -1,6 +1,6 @@
type: txt
help: Match on Differentiated Services Codepoint (DSCP)
-syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --dscp \"$VAR(@)\""
+syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --dscp $VAR(@)"
allowed: awk '
/^#/ { next }
{ printf "%s ", $2 }' </etc/iproute2/rt_dsfield
diff --git a/templates/qos-policy/round-robin/node.tag/class/node.tag/match/node.tag/ip/protocol/node.def b/templates/qos-policy/round-robin/node.tag/class/node.tag/match/node.tag/ip/protocol/node.def
index 1938d04..9c665c2 100644
--- a/templates/qos-policy/round-robin/node.tag/class/node.tag/match/node.tag/ip/protocol/node.def
+++ b/templates/qos-policy/round-robin/node.tag/class/node.tag/match/node.tag/ip/protocol/node.def
@@ -1,6 +1,6 @@
type: txt
help: Match IP protocol name or number
-syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --protocol \"$VAR(@)\""
+syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --protocol $VAR(@)"
allowed: awk '
/^#/ { next }
{ printf "%s ", $1 }' </etc/protocols
diff --git a/templates/qos-policy/round-robin/node.tag/class/node.tag/match/node.tag/ipv6/dscp/node.def b/templates/qos-policy/round-robin/node.tag/class/node.tag/match/node.tag/ipv6/dscp/node.def
index 4f3f18e..d02dc5c 100644
--- a/templates/qos-policy/round-robin/node.tag/class/node.tag/match/node.tag/ipv6/dscp/node.def
+++ b/templates/qos-policy/round-robin/node.tag/class/node.tag/match/node.tag/ipv6/dscp/node.def
@@ -1,6 +1,6 @@
type: txt
help: Match on Differentiated Services Codepoint (DSCP)
-syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --dscp \"$VAR(@)\""
+syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --dscp $VAR(@)"
allowed: awk '
/^#/ { next }
{ printf "%s ", $2 }' </etc/iproute2/rt_dsfield
diff --git a/templates/qos-policy/round-robin/node.tag/class/node.tag/match/node.tag/ipv6/protocol/node.def b/templates/qos-policy/round-robin/node.tag/class/node.tag/match/node.tag/ipv6/protocol/node.def
index 1938d04..9c665c2 100644
--- a/templates/qos-policy/round-robin/node.tag/class/node.tag/match/node.tag/ipv6/protocol/node.def
+++ b/templates/qos-policy/round-robin/node.tag/class/node.tag/match/node.tag/ipv6/protocol/node.def
@@ -1,6 +1,6 @@
type: txt
help: Match IP protocol name or number
-syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --protocol \"$VAR(@)\""
+syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --protocol $VAR(@)"
allowed: awk '
/^#/ { next }
{ printf "%s ", $1 }' </etc/protocols
diff --git a/templates/qos-policy/traffic-limiter/node.tag/class/node.tag/bandwidth/node.def b/templates/qos-policy/traffic-limiter/node.tag/class/node.tag/bandwidth/node.def
index a87dd30..21a46a4 100644
--- a/templates/qos-policy/traffic-limiter/node.tag/class/node.tag/bandwidth/node.def
+++ b/templates/qos-policy/traffic-limiter/node.tag/class/node.tag/bandwidth/node.def
@@ -1,6 +1,6 @@
type: txt
help: Set the traffic-limit used for this class
-syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --rate \"$VAR(@)\""
+syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --rate $VAR(@)"
comp_help: Allowed values:
<number> Bandwidth in Kbps
<number><suffix> Value with scaling suffix
diff --git a/templates/qos-policy/traffic-limiter/node.tag/class/node.tag/burst/node.def b/templates/qos-policy/traffic-limiter/node.tag/class/node.tag/burst/node.def
index 54ae4f3..e22453c 100644
--- a/templates/qos-policy/traffic-limiter/node.tag/class/node.tag/burst/node.def
+++ b/templates/qos-policy/traffic-limiter/node.tag/class/node.tag/burst/node.def
@@ -1,7 +1,7 @@
type: txt
help: Set the burst size for this class (default: 15kb)
default: "15k"
-syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --burst \"$VAR(@)\""
+syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --burst $VAR(@)"
comp_help: Allowed values:
<number> Burst size in bytes
<number><suffix> Size with scaling suffix (kb, mb, gb)
diff --git a/templates/qos-policy/traffic-limiter/node.tag/class/node.tag/match/node.tag/ip/dscp/node.def b/templates/qos-policy/traffic-limiter/node.tag/class/node.tag/match/node.tag/ip/dscp/node.def
index 4f3f18e..d02dc5c 100644
--- a/templates/qos-policy/traffic-limiter/node.tag/class/node.tag/match/node.tag/ip/dscp/node.def
+++ b/templates/qos-policy/traffic-limiter/node.tag/class/node.tag/match/node.tag/ip/dscp/node.def
@@ -1,6 +1,6 @@
type: txt
help: Match on Differentiated Services Codepoint (DSCP)
-syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --dscp \"$VAR(@)\""
+syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --dscp $VAR(@)"
allowed: awk '
/^#/ { next }
{ printf "%s ", $2 }' </etc/iproute2/rt_dsfield
diff --git a/templates/qos-policy/traffic-limiter/node.tag/class/node.tag/match/node.tag/ip/protocol/node.def b/templates/qos-policy/traffic-limiter/node.tag/class/node.tag/match/node.tag/ip/protocol/node.def
index 1938d04..9c665c2 100644
--- a/templates/qos-policy/traffic-limiter/node.tag/class/node.tag/match/node.tag/ip/protocol/node.def
+++ b/templates/qos-policy/traffic-limiter/node.tag/class/node.tag/match/node.tag/ip/protocol/node.def
@@ -1,6 +1,6 @@
type: txt
help: Match IP protocol name or number
-syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --protocol \"$VAR(@)\""
+syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --protocol $VAR(@)"
allowed: awk '
/^#/ { next }
{ printf "%s ", $1 }' </etc/protocols
diff --git a/templates/qos-policy/traffic-limiter/node.tag/class/node.tag/match/node.tag/ipv6/dscp/node.def b/templates/qos-policy/traffic-limiter/node.tag/class/node.tag/match/node.tag/ipv6/dscp/node.def
index 4f3f18e..d02dc5c 100644
--- a/templates/qos-policy/traffic-limiter/node.tag/class/node.tag/match/node.tag/ipv6/dscp/node.def
+++ b/templates/qos-policy/traffic-limiter/node.tag/class/node.tag/match/node.tag/ipv6/dscp/node.def
@@ -1,6 +1,6 @@
type: txt
help: Match on Differentiated Services Codepoint (DSCP)
-syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --dscp \"$VAR(@)\""
+syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --dscp $VAR(@)"
allowed: awk '
/^#/ { next }
{ printf "%s ", $2 }' </etc/iproute2/rt_dsfield
diff --git a/templates/qos-policy/traffic-limiter/node.tag/class/node.tag/match/node.tag/ipv6/protocol/node.def b/templates/qos-policy/traffic-limiter/node.tag/class/node.tag/match/node.tag/ipv6/protocol/node.def
index 1938d04..9c665c2 100644
--- a/templates/qos-policy/traffic-limiter/node.tag/class/node.tag/match/node.tag/ipv6/protocol/node.def
+++ b/templates/qos-policy/traffic-limiter/node.tag/class/node.tag/match/node.tag/ipv6/protocol/node.def
@@ -1,6 +1,6 @@
type: txt
help: Match IP protocol name or number
-syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --protocol \"$VAR(@)\""
+syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --protocol $VAR(@)"
allowed: awk '
/^#/ { next }
{ printf "%s ", $1 }' </etc/protocols
diff --git a/templates/qos-policy/traffic-shaper/node.tag/bandwidth/node.def b/templates/qos-policy/traffic-shaper/node.tag/bandwidth/node.def
index 76fa6e2..eb0d4d9 100644
--- a/templates/qos-policy/traffic-shaper/node.tag/bandwidth/node.def
+++ b/templates/qos-policy/traffic-shaper/node.tag/bandwidth/node.def
@@ -1,8 +1,8 @@
type: txt
help: Set the available bandwidth for this policy
default: "auto"
-syntax:expression: exec "[[ \"$VAR(@)\" == \"auto\" ]] || \
- /opt/vyatta/sbin/vyatta-qos-util.pl --rate \"$VAR(@)\""
+syntax:expression: $VAR(@) == "auto" || \
+ exec "/opt/vyatta/sbin/vyatta-qos-util.pl --rate $VAR(@)"
comp_help: Allowed values:
auto Set bandwidth based on interface speed (default)
<number> Bandwidth in Kbps
diff --git a/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/bandwidth/node.def b/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/bandwidth/node.def
index 6f15037..91d7762 100644
--- a/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/bandwidth/node.def
+++ b/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/bandwidth/node.def
@@ -1,7 +1,7 @@
type: txt
default: "100%"
help: Set the bandwidth used for this class
-syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --percent-or-rate \"$VAR(@)\""
+syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --percent-or-rate $VAR(@)"
comp_help: Allowed values:
<number> Bandwidth in Kbps
<number>%% Percentage of overall rate (default 100%%)
diff --git a/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/burst/node.def b/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/burst/node.def
index 54ae4f3..e22453c 100644
--- a/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/burst/node.def
+++ b/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/burst/node.def
@@ -1,7 +1,7 @@
type: txt
help: Set the burst size for this class (default: 15kb)
default: "15k"
-syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --burst \"$VAR(@)\""
+syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --burst $VAR(@)"
comp_help: Allowed values:
<number> Burst size in bytes
<number><suffix> Size with scaling suffix (kb, mb, gb)
diff --git a/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/ceiling/node.def b/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/ceiling/node.def
index 11bf6b9..09ba853 100644
--- a/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/ceiling/node.def
+++ b/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/ceiling/node.def
@@ -1,6 +1,6 @@
type: txt
help: Set the bandwidth limit for this class
-syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --percent-or-rate \"$VAR(@)\""
+syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --percent-or-rate $VAR(@)"
comp_help: Allowed values:
<number> Limit in Kbps
<number>%% Percentage of overall rate
diff --git a/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/ip/dscp/node.def b/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/ip/dscp/node.def
index 4f3f18e..d02dc5c 100644
--- a/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/ip/dscp/node.def
+++ b/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/ip/dscp/node.def
@@ -1,6 +1,6 @@
type: txt
help: Match on Differentiated Services Codepoint (DSCP)
-syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --dscp \"$VAR(@)\""
+syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --dscp $VAR(@)"
allowed: awk '
/^#/ { next }
{ printf "%s ", $2 }' </etc/iproute2/rt_dsfield
diff --git a/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/ip/protocol/node.def b/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/ip/protocol/node.def
index 1938d04..9c665c2 100644
--- a/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/ip/protocol/node.def
+++ b/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/ip/protocol/node.def
@@ -1,6 +1,6 @@
type: txt
help: Match IP protocol name or number
-syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --protocol \"$VAR(@)\""
+syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --protocol $VAR(@)"
allowed: awk '
/^#/ { next }
{ printf "%s ", $1 }' </etc/protocols
diff --git a/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/ipv6/dscp/node.def b/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/ipv6/dscp/node.def
index 4f3f18e..d02dc5c 100644
--- a/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/ipv6/dscp/node.def
+++ b/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/ipv6/dscp/node.def
@@ -1,6 +1,6 @@
type: txt
help: Match on Differentiated Services Codepoint (DSCP)
-syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --dscp \"$VAR(@)\""
+syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --dscp $VAR(@)"
allowed: awk '
/^#/ { next }
{ printf "%s ", $2 }' </etc/iproute2/rt_dsfield
diff --git a/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/ipv6/protocol/node.def b/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/ipv6/protocol/node.def
index 1938d04..9c665c2 100644
--- a/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/ipv6/protocol/node.def
+++ b/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/match/node.tag/ipv6/protocol/node.def
@@ -1,6 +1,6 @@
type: txt
help: Match IP protocol name or number
-syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --protocol \"$VAR(@)\""
+syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --protocol $VAR(@)"
allowed: awk '
/^#/ { next }
{ printf "%s ", $1 }' </etc/protocols
diff --git a/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/set-dscp/node.def b/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/set-dscp/node.def
index 4e54850..2fbddac 100644
--- a/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/set-dscp/node.def
+++ b/templates/qos-policy/traffic-shaper/node.tag/class/node.tag/set-dscp/node.def
@@ -1,6 +1,6 @@
type: txt
help: Change the Differentiated Services (DiffServ) field in the IP header
-syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --dscp \"$VAR(@)\""
+syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --dscp $VAR(@)"
allowed: awk '
/^#/ { next }
{ printf "%s ", $2 }' </etc/iproute2/rt_dsfield
diff --git a/templates/qos-policy/traffic-shaper/node.tag/default/bandwidth/node.def b/templates/qos-policy/traffic-shaper/node.tag/default/bandwidth/node.def
index 4d454d4..3743688 100644
--- a/templates/qos-policy/traffic-shaper/node.tag/default/bandwidth/node.def
+++ b/templates/qos-policy/traffic-shaper/node.tag/default/bandwidth/node.def
@@ -1,6 +1,6 @@
type: txt
help: Set the bandwidth used for default traffic
-syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --percent-or-rate \"$VAR(@)\""
+syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --percent-or-rate \$VAR(@)"
comp_help: Allowed values:
<number> Bandwidth in Kbps per second
<number>%% Percentage of overall rate
diff --git a/templates/qos-policy/traffic-shaper/node.tag/default/burst/node.def b/templates/qos-policy/traffic-shaper/node.tag/default/burst/node.def
index 81e468a..f21eb9b 100644
--- a/templates/qos-policy/traffic-shaper/node.tag/default/burst/node.def
+++ b/templates/qos-policy/traffic-shaper/node.tag/default/burst/node.def
@@ -1,7 +1,7 @@
type: txt
help: Set the burst size for default traffic
default: "15k"
-syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --burst \"$VAR(@)\""
+syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --burst $VAR(@)"
comp_help: Allowed values:
<number> Burst size in bytes
<number><suffix> Size with scaling suffix (kb, mb, gb)
diff --git a/templates/qos-policy/traffic-shaper/node.tag/default/ceiling/node.def b/templates/qos-policy/traffic-shaper/node.tag/default/ceiling/node.def
index 19234d9..a0cc58b 100644
--- a/templates/qos-policy/traffic-shaper/node.tag/default/ceiling/node.def
+++ b/templates/qos-policy/traffic-shaper/node.tag/default/ceiling/node.def
@@ -1,6 +1,6 @@
type: txt
help: Set the bandwidth limit for default traffic
-syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --percent-or-rate \"$VAR(@)\""
+syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --percent-or-rate $VAR(@)"
comp_help: Allowed values:
<number> Limit in Kbps
<number>%% Percentage of overall rate
diff --git a/templates/qos-policy/traffic-shaper/node.tag/default/set-dscp/node.def b/templates/qos-policy/traffic-shaper/node.tag/default/set-dscp/node.def
index 5d20cf9..a469ae8 100644
--- a/templates/qos-policy/traffic-shaper/node.tag/default/set-dscp/node.def
+++ b/templates/qos-policy/traffic-shaper/node.tag/default/set-dscp/node.def
@@ -1,6 +1,6 @@
type: txt
help: Change the Differentiated Services (DiffServ) field in the IP header
-syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --dscp \"$VAR(@)\""
+syntax:expression: exec "/opt/vyatta/sbin/vyatta-qos-util.pl --dscp $VAR(@)"
allowed: awk '
/^#/ { next }
{ printf "%s ", $2 }' </etc/iproute2/rt_dsfield