summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStephen Hemminger <stephen.hemminger@vyatta.com>2010-06-07 10:46:43 -0700
committerStephen Hemminger <stephen.hemminger@vyatta.com>2010-06-07 15:56:10 -0700
commit31a8ab66f49ad26b376d552ec468b21e15835daf (patch)
tree50a0d0eb271f1bb830668ce018c3b1d7027570b5 /Makefile.am
parenta6fc0cd96c30422732fd4006dfed22fedc4c624d (diff)
downloadvyatta-cfg-qos-31a8ab66f49ad26b376d552ec468b21e15835daf.tar.gz
vyatta-cfg-qos-31a8ab66f49ad26b376d552ec468b21e15835daf.zip
Rearrange Qos commands for Larkspur
Current (Kenwood and earlier): set qos-policy traffic-shaper TS { ...classes } set qos-policy traffic-limiter TL { ...classes } seq qos-policy network-emulator NE ... set qos-policy random-detect RD ... set qos-policy rate-limiter RC ... set qos-policy round-robin RR ... set interfaces ethernet eth0 qos-policy out TS set interfaces ethernet eth0 qos-policy in TL New (Larkspur and later): set traffic-policy shaper TS { ...classes } set traffic-policy limiter TL { ...classes } seq traffic-policy network-emulator NE ... set traffic-policy random-detect RD ... set traffic-policy rate-control RC ... set traffic-policy round-robin RR ... set interfaces ethernet eth0 traffic-policy out TS set interfaces ethernet eth0 traffic-policy in TL set interfaces ethernet eth0 redirect ifb0 set interfaces ethernet eth0 mirror eth2 Note: 1. Only one of the following is allowed: "redirect", or "mirror" 2. Traffic-policy limiter is allowed with redirection/mirror and takes place before mirror/redirect action (NEW) 3. Limiter policy may applied on output (NEW) 4. Only limiter policies can be applied on input (same as previous releases) This does add some new functionality (#2, and #3) which are possible because of how filter classes are implemented.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 1 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index d0971a8..7ca18c1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -17,9 +17,7 @@ share_perl5_DATA += lib/Vyatta/Qos/LimiterClass.pm
share_perl5_DATA += lib/Vyatta/Qos/RoundRobin.pm
share_perl5_DATA += lib/Vyatta/Qos/NetworkEmulator.pm
share_perl5_DATA += lib/Vyatta/Qos/RandomDetect.pm
-share_perl5_DATA += lib/Vyatta/Qos/IngressLimit.pm
-share_perl5_DATA += lib/Vyatta/Qos/IngressRedirect.pm
-share_perl5_DATA += lib/Vyatta/Qos/IngressMirror.pm
+share_perl5_DATA += lib/Vyatta/Qos/TrafficLimiter.pm
etcdir = /etc
etc_SCRIPTS =